1

I'm trying to install an application using the App Store on Mavericks. The download succeeds, but the install hangs at the very end of the process. I've been through the standard procedures (multiple restarts, cache clears, login / logout, etc).

I tailed the install.log, which revealed the following:

Apr  5 21:28:46 swift.local _atsserver[3347]: Running Install Scripts . . .
Apr  5 21:28:46 swift.local _atsserver[3349]: Begin script: Pages_PP
Apr  5 21:28:46 swift.local _atsserver[3353]: End script: Pages_PP
Apr  5 21:28:47 swift.local _atsserver[3354]: Begin script: updateHelpPost
Apr  5 21:28:47 swift.local installd[3164]: postinstall: shell-init: error retrieving current directory: getcwd: cannot access parent directories: Permission denied
Apr  5 21:28:47 swift.local installd[3164]: postinstall: 2014-04-05 21:28:47.067 defaults[3358:d07]
Apr  5 21:28:47 swift.local installd[3164]: postinstall: Domain (com.apple.helpd) not found.
Apr  5 21:28:47 swift.local installd[3164]: postinstall: Defaults have not been changed.
Apr  5 21:28:47 swift.local installd[3164]: postinstall: find: .: Permission denied

It looks like something is wrong with the permissions on install. I used the disk utility to fix all the permissions on the machine and still no luck.

Any insight would be awesome!

  • 1
    Does this occures with just one application? – gattol Apr 9 '14 at 14:17
  • Try creating another user, see if when you are logged in as the new user, whether the same behavior occurs. – David DelMonte Apr 10 '14 at 13:17
  • It happens with the latest versions of Keynote and Pages. Same behavior on other users. – Swift Apr 10 '14 at 14:51
  • Is helpd running? (ps aux | grep helpd) – sdmeyers Apr 11 '14 at 13:54
1

Based on the error log you provided it looks like helpd has crashed or is causing some issues. This will mess up all kinds of stuff.

try:

  1. rm -rf ~/Library/Caches/com.apple.helpd
  2. rm ~/Library/Preferences/com.apple.helpd.plist ~/Library/Preferences/com.apple.help.plist
  3. Restart computer
  4. Try again

Warning: rm = remove, rm -rf = Remove recursively. Use with caution.

  • 1
    You should add a Warning to those commands explaining the result. – Ruskes Apr 11 '14 at 14:20
0

The problem(s) appear to stem from nothing more than a (simple) permissions issue:

Open DiskUtility.app then verify and repair your volume(s).

Check the output to determine if something is amiss; It's normal for DiskUtility to find permissions and repair them each time, but does anything standout as really abnormal? Doing this should set the permissions correctly throughout your system / volume(s). After you've let DiskUtility.app run it's course you can try installing the application again. If that's unsuccessful you can perform an additional step; update the locate database.

Open Terminal.app (Substituting Username with yours):

sudo -u Username /usr/libexec/locate.updatedb

Executing this command updates the database that scripts utilize (like those found within installers) to locate command-line tools they might be relying on to perform particular tasks (such as find for example).


Performing these two tasks are often enough to fix common permissions related issues that may have gotten changed on your system for whatever reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .