7

If I connect an HDMI cable to my MacBook (mid-2010 white model, Mavericks 10.9.2) and play a video, then the audio comes out of the TV - so far so good.

If I then close the lid while the video is playing, the TV screen flickers a bit but then continues playing, but the audio starts coming out of the internal speakers.

Is there any way to stop this and force the MacBook to continue to play via the HDMI when that's the only screen in use?

Extra Info: re-opening the lid doesn't switch audio back to TV but all settings suggest the TV is the selected audio output device. If I pause the video, THEN switch to internal speakers and back to TV, audio will be back to TV if/when I restart the video playback.

1

You didn't mention what media player you're using.

Personally I use VLC Media Player. With VLC you can explicitly set the audio device in the menubar > audio > Audio Device > HDMI, in your case. I use VLC in conjunction with NoSleep to close my laptop while playing media. The screen turns off when I close the lid, but the computer stays awake. The brightness button also will step/dim down to "display off" on my laptop. I usually opt to do it this way instead of closing the lid all the way so as to be able to pause and play and also to keep the laptop from getting hot. Not sure if an older model like yours will do that, do let me know.

0

You must check your sound settings thoroughly but I think this may be a default setting unfortunately! You may just have to ignore it and keep your MacBook open. 😔

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .