1

I have a very annoying problem with my Mac. My default country is somehow set to the Netherlands. Whenever I open Google with Safari or another Web browser, I get redirected to google.nl. I also cannot use my Spotify account anymore because it says that I need to be in my home country. How can I change that? I already tried using System Preferences -> Language & Region, but that does't work.

2

Google and Spotify are most likely showing you Netherlands information because they are associating your IP address to a location in the Netherlands.

This isn't a setting that is controlled from your browser, but is a component of your internet connection that services use for various reasons to personalize the experience to the user, without knowing much (yet) about the user themselves.

For example, if I VPN (tunnel my internet connection to make it look like I'm from a server physically located elsewhere) from the US to the UK, Google automatically directs me to the UK Google page, and I can watch Al Jazerra English and BBC. (both unavailable-ish in the US) Similarly, those services think you are physically in the Netherlands, and they behave accordingly; Google directs you to it's .nl service, and Spotify likely doesn't have streaming agreements in the country, so it cannot legally service those in the Netherlands.

Now, you don't mention where you are physically, so it is possible that you are not physically in the Netherlands, but whatever service Google and Spotify use to associate an IP with a general location says that you are, likely because (some time in the past) that IP address was associated with a location in the Netherlands. If that's the case ... you may need to contact your ISP to see if they have a remedy for this kind of problem.

  • I'm from Germany. Indeed I was in the Netherlands for a couple of weeks, but that was month ago. Ok, I will contact my ISP and see if they can help me. – Javiator Apr 4 '14 at 15:02
  • How can I check on OS X If I'm using a proxy? – Javiator Apr 4 '14 at 15:06
  • System Preferences > Network; choose the method you're connecting with on the left and go to "Advanced...". You'll see a proxy tab. – bradleyjx Apr 4 '14 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .