41

Today I tried opening the App Store to update some software, but when it opens I am left with a blank screen:

Blank App Store Screen

Also, when I click on the menu items in the top bar, multiple items will highlight in blue (but the blank screen will not change):

enter image description here

Does anyone know why this is happening? I am using Mac OSX 9.1 (Mavericks).

  • 1
    I don't know why that's happening, but the first step I'd take is to restart – dwightk Apr 2 '14 at 16:12
  • 3
    Seriously, all this time and the best answer we have is "reboot'? I have had this problem for months, and I reboot, then it works for a little bit, then the problem comes back again. I shouldn't have to reboot constantly just to go to the App Store. Very annoying. – user78402 May 17 '14 at 15:23
  • 1
    2 years later and they still haven't fixed this. – Teflon Ted Jun 3 '16 at 14:59

10 Answers 10

75

I killed all store* processes in Activity Monitor. Then relaunched App Store and it started working.

  • 2
    Thanks. It was killing storeagent in particular that fixed it for me. – Syclone0044 Jun 22 '15 at 0:13
  • Nice, worked for me as well. – terrace Oct 7 '15 at 17:48
  • 1
    Weirdly, not even a reboot fixed this problem. But manually killing these processes did it. – Glenn Schmidt Mar 24 '16 at 12:31
  • It's always terrible when killing system processes solves a problem – 130e13a May 5 '16 at 6:53
  • This doesn't work in macOS Sierra. It still shows blank page of it. Is there any other way to fix this? – chenghuayang Apr 5 '18 at 10:07
10

Mine would always freeze when trying to open it, I tried killing the processes, signing out through iTunes, restarting, and nothing worked. I ended up updating the OS and iTunes through terminal and once I restarted the app store worked again!

From terminal, typing

softwareupdate -l

will give you the available updates. Then you can install them doing something similar to:

softwareupdate -i OSXUpd10.10.4-10.10.4

based off the list of available updates.

Source: http://osxdaily.com/2015/07/01/fix-frozen-app-store-updates-and-high-softwareupdated-cpu/

  • 1
    Also softwareupdate -i -a will install updates. – Meekohi Apr 5 '18 at 14:54
4

I just had this problem, poked around online, and solved it by resetting the NVRAM. It's generally my second go-to solution if rebooting doesn't fix it.
Here are the Mavericks NVRAM reset instructions:
http://support.apple.com/kb/PH14222?viewlocale=en_US

Resetting NVRAM

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R.
  3. Turn on your Mac.
  4. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  5. Hold these keys until the computer restarts and you hear the startup sound for a second time.
  6. Release the keys.
1

Certificate solution did not work for me, reboot did not work for me.

Killed storeuid process under my user account, opened App Store and it was fixed.

1

I've been having the same issue under OS X 10.11 El Capitan where the App Store would open to a blank page and no errors were listed.

The main solutions I have seen on multiple sites are:

  1. Kill "store" Processes (see this thread)
  2. Zap NVRAM (Used to be called PRAM) [Reboot and hold down command-option-p-r until it cycles through the reboot sound 2-3 times]
  3. Use the terminal commands to delete preference files (plist)
  4. Remove Anti-Virus/Mal-ware software
  5. Check network settings and remove any proxies
  6. In the App Store Go to the Store menu and "Sign Out"

#4 and #5 didn't apply to me

I did perform #3 but didn't see any help from that.

What worked for me was a combination of killing the processes (#1), restarting the App Store, and "Sign Out" (#6). Which worked great -- I had a bunch of pending updates.

But then I rebooted and the issue of the empty App Store came back. This time I tried just the "Sign Out" and that didn't work. Killed the processes and opened the App Store and it worked.

I'm going to experiment with the NVRAM zapping and see if that works on a permanent basis. Otherwise I'll open up a bug report with Apple.

0

I had the same problem today..tried rebooting and working fine now.

0

I'm new to Mac and I thought my App Store wasn't working as all buttons were greyed out. Turns out I had no Internet connection :-(

I feel a bit stupid but you'd think OSX would pop up a quick error message telling me that.

0

Found Safari would not open any sites, however VNC worked fine. Go to Preference, Network, advance button at bottom, then look at the DNS tab. I found both DNS Servers and Search Domains were blank. Added my DNS info and Domains to search. Started to work. :)

0

Same problem. Tried all the solutions mentioned in this and other threads. Opened iTunes on a whim and saw the system could not authenticate the various CERTS associated with Apple. Looked that up. Found that the solution was to purge your current key store and then reboot. Voila.

In my case, I'm assuming my keystore "corruption" happened because of a system lock up which required a hard reboot. But this solved it.

0

First, close the app store or itunes, etc. I fixed this by opening a terminal, then getting a super user terminal: sudo su - enter your password now be careful. You are root.

Next we want to kill all the App Store related processes. This doesn't hurt anything. Let's find them using the ps command and then using the grep search utility to get down to what we want.

MacBook-Pro:~ root# ps -ef |grep store |grep -vi google
  501  9284     1   0 21Dec15 ??         0:08.90 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeassetd
  501  9349     1   0 21Dec15 ??         0:00.73 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeinappd
  501  9353     1   0 21Dec15 ??         0:01.91 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storedownloadd
  501  9459     1   0 21Dec15 ??         0:00.17 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storelegacy

The second column is the process ID we want. We want to use the kill command:

kill 9284 9349 9353 9459

The numbers will be different on your PC. Open up app store and it should work! I have also read other ways - removing some verisign keys from the key chain app, and others, but this is what fixed me.

  • this is somewhat unsafe as a race condition is possible — if at least one of these processes dies during the time window before ps and kill, you may end up killing some other process if it gets the same PID (which is unlikely but possible). better to use killall command, or at least do it all from a script to minimize the delay. – Sarge Borsch Mar 30 '18 at 6:39

You must log in to answer this question.

protected by bmike Jan 25 '16 at 22:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .