I have local admin rights on my mac laptop at work but work has MDM restrictions in place.

In the last several days I have lost access to several system preference pane items. Most notably "security and privacy" and notifications.

The icons are now grey and when I hover over them they display "your system administrator has not given you access to this preference pane"

How do I re-enable these preferences?

4 Answers 4


On ElCapitan

With System Prefs not running:

  • Go to: Hard Drive Name/Library/Managed Preferences/administrator
  • Delete or (rename to *_old) com.apple.systempreferences.plist
  • Run System Prefs, all should now be visible
  • 1
    I renamed the file /Library/Managed Preferences/<MYUSER>/com.apple.systempreferences.plist to solve the issue.
    – setempler
    Commented Aug 21, 2017 at 5:54
  • @Wyatt's Solution worked for me too on High Sierra. Only difference is that blocked panes are still not coming under the "View" Menu item, but searching for them works just fine.
    – ghitesh
    Commented Nov 16, 2018 at 4:43
  • That file doesn't exist on Catalina
    – garryp
    Commented May 16, 2020 at 9:44

I have found a work around that is a bit hackish.

You can read the details here: http://walkingtowel.org/2010/02/25/accessing-mac-os-x-leopard-greyed-out-preference-panes/

In case the link goes bad, here are the steps suggested:

  1. copy the system prefs app
  2. in /Applications/System\ Preferences\ copy.app/Contents/Resources, rename or delete NSPrefPaneGroups.xml
  3. Make sure preferences is not running
  4. Launch the copied version
  5. note the empty pane -> use the view menu (all pane exist here)
  • 2
    As far as I can tell, it looks like this doesn't work in Yosemite any more. This definitely worked in previous versions of OSX, but now that I've upgraded, even the View menu has the preferences panes my corporate overlords don't want me to see filtered out (they just don't appear in the list)... dang it! Commented Mar 12, 2015 at 17:40
  • This worked for me on Mojave. The copied app will open up blank, but if you use the search in the right-hand corner it will take you to that preference. Commented Aug 9, 2019 at 23:18
  • 1
    Got a new work mac on Monterey 12.1 and this no longer seems to be a functioning workaround. Commented Mar 15, 2022 at 20:52

I don't have a fix for 10.11 El Capitan, but I think I know where the problem is. On my system, my IT department put in managed preferences, even for Admin accounts. The list of allowed preferences can be found in /Hard Drive Name/Library/Managed Preferences/User Name/complete.plist

About 3/4 of the way down the file I see the enabled preferences as:


However, I can't seem to permanently change the file. I've tried copying to my desktop and modifying (both with TextWangler and with Xcode) then moving it back (authentication needed of course) but it doesn't change which preferences are activated when restarting System Preference. I think this file is only read on login. Also, the file reverts back to its original state after I log out and back in, so the changes can't be activated as the file reverts before System Preferences loads it. Is there a way to get System Preferences to re-read the complete.plist file after it is changed?

  • I have the same issue. It seems apple moved away this part from the above mentioned file with the latest OS update. EnabledPreferencePanes key is not there even in neighbor files.
    – svural
    Commented May 3, 2016 at 15:10

Simply restarting the mac seems to have resolved the issue for me. I'm guessing this answer tells what's really going on:

If the other account is logged in (possible if you have "fast user switching" enabled), you will not be able to make any changes to that account from System Preferences, even as administrator. To reset their password, they cannot be logged in. If you can't log that user out, you can restart the computer to force it to be logged out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .