I want to use Migration Assistant to transfer data between two macbook pros, both on OS X 10.9.2.

I have them connected via thunderbolt ethernet adapters.

When I go into migration assistant on the target, I can see and select the source and I see a code. The source says on the "Migrate to another Mac" screen "Looking for other computers" forever.

I've ensured that the firewall is off on the source, and that the sharing settings look the same.

What else can I check/try to get this working?

  • 2
    I figured out how to make this work, and hopefully this will help someone else. I had to turn off wifi on both machines, and manually assign an IP addresses in the same network to the thunderbolt ethernet ports.
    – brl8
    Mar 31, 2014 at 20:46
  • You should make that in a answer !
    – Ruskes
    Mar 31, 2014 at 21:17
  • it told me I can't for 8 more hours and I was worried I would forget to come back here. :)
    – brl8
    Mar 31, 2014 at 21:37
  • here I gave you some points, and that goes fast then you can do much more here, we wont you to participate and share your knowledge and findings here.
    – Ruskes
    Mar 31, 2014 at 21:58
  • The best way is to boot the source mac in target mode (just hold down T when starting up) and then its SSD will instantly appear as a source for the target mac in migration assistant. No network or other nonsense required.
    – tim
    Nov 16, 2015 at 10:41

8 Answers 8


I solved the problem by configuring on both macs IPV6 to automatic (one has "disabled", the other "automatic").

Hope it will help everybody in the future.


  • Not sure why this is the fix but it works Oct 25, 2016 at 17:37

I had this same problem in 10.9 trying to migrate across the network -- the source computer would spin its wheels, forever looking for a destination, while the destination computer would immediately find the source.

I accidentally clicked on the icon for the source computer of the destination computer's Migration Assistant and the "next" button ungrayed itself. Upon clicking the button, the source computer's migration assistant showed the proper screen and I was able to continue as normal.


For me, the problem was the my source computer had the firewall turned on. Once I turned it off, all worked as expected. (Code showed up, M.A. worked properly.)

System Prefs -> Security -> Firewall -> Turn Firewall Off.


Happened to me too..

Make sure you click on the time machine disk that shows up in the "transfer information to this mac" screen.

Once you click it, you should be able to continue.

(i also turned off wifi and disconnected network cable as my source was an external hd)

good luck


Yes, I think this is largely a bad usability issue. You do not need the source computer to see the target computer. You select the source computer in the target's Migration Assistant panel and press "Continue" on the target computer. Then, go to source computer and press continue after ensuring that the same verification code is displayed.

This may not work for all users and does not seem to affect that Thunderbolt never works. I have no idea what Thunderbolt is supposed to do except sell $40 cables that convey no data, ever.

  • The whole problem is that the code never shows up on the source computer.
    – Olie
    Sep 27, 2014 at 2:04

Someone posted the key to this issue above. Once one of the computers finds the source (or destination) click the "next" button on that computer. The "looking" wheel will spin forever unless you do that.


As soon as I turned off the firewall, the code showed up on my PC.


Folks, I was using a direct Ethernet connection between an old ('08) laptop (10.6.8) to a new MacBook (10.10.1), and having updated all software (Software Update doesn't tell you that MA needs updating; you have to do it manually), I was still seeing the source from the target, but the source was unable to see the target.

After a long(!) exchange with Apple, what worked was to create a new location on each machine (I gave them the same name, in case that matters) and then reboot both machines. After turning off wifi, which comes on automatically upon boot, MA performed perfectly...

Hope that helps...

  • What do you mean by "create a new location" on each machine? Nov 24, 2015 at 5:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .