9

In Energy Saver settings (System Preferences -> Hardware section) the Mac is set to sleep after 15 minutes, but nothing happens.

Mac drains battery and automatically turns off when battery is low.

If I type pmset -g assertions in terminal, I get this:

3/31/14 5:46:52 AM EDT   
Assertion status system-wide:
PreventUserIdleDisplaySleep    0
PreventSystemSleep             0
PreventUserIdleSystemSleep     1
InternalPreventDisplaySleep    0
ExternalMedia                  0
UserIsActive                   0
ApplePushServiceTask           0
BackgroundTask                 0

Listed by owning process:
  pid 251(coreaudiod): [0x0000000100000d01] 00:17:27 NoIdleSleepAssertion named: "com.apple.audio.'AppleHDAEngineOutput:1B,0,1,1:0'.noidlesleep" 
  pid 251(coreaudiod): [0x0000000100000929] 01:11:47 NoIdleSleepAssertion named: "com.apple.audio.'BoomEngine:0'.noidlesleep" 
  pid 269(helpd): [0x0000000c00000159] 02:37:33 BackgroundTask named:     "com.apple.helpd.sdmbuilding" 

Kernel Assertions: None

How should I read this? Why PreventUserIdleSystemSleep is set to one? How I can set up Mac go to sleep after certain time of inactivity?

7

In this instance, use Activity Monitor.app to kill process pid 251(coreaudiod).

Tracking Down Idle Sleep Problems

Below is an overview for tracking down why your Mac will not idle sleep.

No Idle Sleep Assertion

A NoIdleSleepAssertion assertion is the most likely reason your Mac is not sleeping.

To see more about which processes are blocking sleep, run this command in Terminal.app:

pmset -g assertions

This will list active assertions and their owning application or process. Expect to see audio visual, network sharing, or printing related responses.

If a hidden process, such as pid 251(coreaudiod), is responsible, you can kill it using Activity Monitor.app. Afterwards rerun the pmset command above to check the assertion has been removed.

Common Causes

This Apple Discussion forum thread, My Mac don't go sleeping since Lion Update, contains numerous people who also encountered this problem. The same causes will affect OS X 10.9.

  • Check for stuck print jobs; a pending print job will keep your Mac awake
  • Check for audio visual or presentation programs that may restrict sleep while playing
  • Killing a core system daemon seems like terrible advice. – augurar Jan 2 '18 at 20:11
  • @augurar Core system daemons are managed and will relaunch when killed. There are bugs within daemons that cause them to stop working correctly. Occasionally a relaunch is the only solution left to the user – short of restarting the computer. – Graham Miln Jan 4 '18 at 17:24
  • Before considering an OS bug, you should first rule out user error and application software issues. In this case, the problem was due to a misbehaving application so killing the audio daemon would be the wrong thing to do and only confuses the issue. – augurar Jan 4 '18 at 19:24
  • @augurar Given you appear to feel strongly about this question and answer, please add your own answer to help the questioner and others better troubleshoot and fix these problems. – Graham Miln Jan 5 '18 at 16:46
  • 1
    Wow, sure glad I found this. I notice my 2011 iMac (running Sierra) wouldn't put the display to sleep, nor would the screen saver kick in. In my case, it was because of Discord! Their app when you first launch it, has this little video loop running advertising new games or whatever else. I never even considered this really to be "video", but the assertion that came up was: pid 413(Discord): [0x0000683300058c91] 00:00:05 NoDisplaySleepAssertion named: "Playing video" As soon as I changed Discord to not show that particular video loop, display sleep and screen saver work fine again. – Jonathan van Clute Jan 26 at 23:47
3

Actually thanks for your detailed report one can see it is the application Boom preventing the sleep mode.

Try one of the following by updating the app Boom to 1.8.1, or disable it to test.

The 1.8.1 has some fixes that might help:

--- Audio clipping(cutting out) issue is now fixed.
--- Kernel task consumption issue has been fixed. Now it functions the same as default OS X with or without Boom.
--- No sound after sleep issue is now resolved.
--- VLC and other media compatibility issue fixed.
--- Volume key sound delay.
Our developers our working with Apple's DST to have a quick fix for this.
--- Audio drop when using Facetime. Mavericks users are advised to turn off Boom when FaceTime is active.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .