1

I have mac book pro late 2013 with os x 10.9.2. When i clicked on the wifi network i want to connect, it doesn't connect. It doesn't even give any response. There is only an animation in wifi: on option in upper right side with loading circle and becomes wifi: looking for networks . And it goes back to normal repeatedly

I tried to fix it by looking into settings, i even re-installed os x but it still doesn't connect. The network i want to connect is fine, there are 2 more devices connected to that network and they work just fine. How can i fix this problem?

  • It might be just your Airport Express user Interface. Lets find out if the network is working at all. – Ruskes Mar 28 '14 at 11:33
  • Have you tried turning it off and on again? – user74283 Mar 28 '14 at 11:37
1

before we go on fixing lets find out it is working at all.

In Terminal type (to turn it on)

networksetup -setairportpower en0 on

Next type (to scan)

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Finally type (to connect)

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

Also:

While holding the alt key click on the wifi icon

In the pop up window select Open Wireless Diagnostics...follow the instructions.

  • 1
    Glad to be of help :) – Ruskes Mar 28 '14 at 12:03
  • Hi. I had the same problem again. and this time when i followed these steps it gives me an error like this: "Failed to join network myNetworkName.." – Timur Aykut YILDIRIM Apr 1 '14 at 13:11
-1

It dying in a session with wifi connection 1 min on my computer. Every time the computer wanted a password again. I changed the password from the modem interface. I entered a new password. This problem has been solved. Maybe you are living. I wanted to note here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .