I am diagnosing some mysterious network latency that comes and goes with my wife's MacBook Pro.

As part of this diagnostic work, I fired up Network Utility and used its interface to traceroute to trace the route to www.google.com. Somewhat oddly, all of the results were of the * * * variety.

Suspicious, I opened up traceroute directly from Terminal and issued traceroute www.google.com. There was a * * * from the second hop (right after my entry) but then everything flowed normally.

I then eliminated DNS issues by using traceroute against the IP address directly.

This behavior happens on all Macs in our house, so it's not computer-specific.

Here is the output from the command line (which worked):

traceroute to (, 64 hops max, 52 byte packets
 1 (  115.994 ms  1.265 ms  1.816 ms
 2  * * *
 3  te-5-2-ur02.bremerton.wa.seattle.comcast.net (  14.209 ms  12.736 ms  11.514 ms
 4  ae-22-0-ar03.seattle.wa.seattle.comcast.net (  18.753 ms  14.804 ms  15.076 ms
 5  he-1-4-0-0-10-cr01.seattle.wa.ibone.comcast.net (  19.233 ms
    he-1-7-0-0-10-cr01.seattle.wa.ibone.comcast.net (  18.523 ms
    he-1-12-0-0-10-cr01.seattle.wa.ibone.comcast.net (  16.625 ms
 6  he-0-11-0-1-pe04.seattle.wa.ibone.comcast.net (  15.435 ms  21.009 ms  14.535 ms
 7 (  16.739 ms  14.500 ms  15.909 ms
 8 (  16.002 ms  17.200 ms  16.781 ms
 9 (  15.472 ms  17.927 ms  15.836 ms
10  sea09s16-in-f20.1e100.net (  15.860 ms  27.057 ms  16.399 ms

And here is the output from Network Utility:

Failed Network Utility traceroute

Leaving aside the &)$(*^#& problem that I'm actually trying to solve, what would account for why the two traceroute invocations would produce different output? If it matters, traceroute-via-Network-Utility never works; the command line always does.

  • Hmm, it does work for me. Does it happen for different users on the same Mac (create new one if needed)? Do you have any web proxy/firewall/parental control enabled?
    – nohillside
    Mar 27, 2014 at 19:35
  • I also tried it on another mac in the house and get the same issue. The only difference I note above (that I can see) is the packet size. Regarding firewalls, both computers have the stock Mac firewall enabled, and the router is a stock Comcast turd that does whatever it does. Mar 27, 2014 at 19:36
  • You can change the packet size when running from shell: traceroute 72
    – nohillside
    Mar 27, 2014 at 19:38
  • Works fine with 72 byte packets. So much for that theory. Any way to see what the Network Utility invocation of traceroute is actually doing? Mar 27, 2014 at 19:40
  • Has anyone solved this? I have the opposite issue. Network utility always returns a full route but the CLI does not.
    – Xogle
    Oct 26, 2017 at 16:44

1 Answer 1


Network Utility is using ICMP rather than the default UDP protocol used by traceroute. You can use the -I flag to get the same behaviour on the command line:

traceroute -I

I don't know of any way to force Network Utility to use UDP.

One explanation for this could be that your firewall/router is configured to block ICMP packets.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .