1

There is a serious ownership/ permissions/ entitlements fault in my 10.7 install.

What happened:

1) After swapping the stock drive for an Intel SSD of the same size in my Mac Mini 1,2 (2006 -ish?), I performed a clean install of 10.7 via target disk mode; That is, I put the mini into TDM and mounted it via FW400 to my iMac which I booted using a 10.7 install USB drive.

2) The install went smooth and the machine boots by itself as expected all the way to the desktop.

3) I try to install the 10.7.5 combo update via Software Update, it fails due to bad checksum.

4) Knowing I get corrupt downloads from several CDNs (incl. Apple) through my janky cable internet, I download the standalone 10.7.5 package to a USB stick at the local library and, having brought it home, etc, run it from the mini's desktop. Fails for unknown reason.

5) Console log indicates that before the installer even started to unpack the updates:

14-03-25 4:18:59.771 PM authorizationhost: SFBuiltinEntitled: Installer.app >is not entitled for system.install.apple-software

14-03-25 4:18:59.813 PM authorizationhost: SFBuiltinEntitled: Installer.app >is not entitled for system.install.app-store-software

14-03-25 4:18:59.853 PM authorizationhost: SFBuiltinEntitled: Installer.app >is not entitled for system.install.app-store-software

14-03-25 4:18:59.856 PM com.apple.SecurityServer: Failed to authorize right >'system.install.app-store-software' by client >'/System/Library/PrivateFrameworks/PackageKit.framework/Versions/A/Resources/>installd' [301] for authorization created by >'/System/Library/CoreServices/Installer.app' [290]

What I've tried: I've tried installing less significant things (like the iTunes update) and get the same error.

I've tried every permutation of repairing disk permissions and fsck from active partition, disk in target mode, single user mode, safe boot, etc. No effect.

I've tried chown-ing things, still no luck.

Somehow the installer has become sandboxed and cannot do stuff, for lack of better language. I'd love some help with this!

  • Does the installer even open? Where does it fail? Does this help (support.apple.com/kb/HT5198)? – PoisonNinja Mar 26 '14 at 1:54
  • @anonymousAppDev: the installer fails after expanding the packages (UI notice is "validating") but before anything actually gets written (When the UI notice changes to "writing files"). Your link is appreciated but unhelpful. While the symptom is the same as an unsigned or expired package certificate, these are fresh downloads from apples update CDN and the problem is consistent across all attempted installs. Thanks for your help! Any other thoughts? – Evan Mar 26 '14 at 5:42
  • Does it ask you for your password before installing? – PoisonNinja Mar 26 '14 at 12:52
  • It does, before expanding the packages, and accepts my root password just fine. I think that because I did the install by target disk mode, the ownership of system directories and their contents (like CoreServices/) is not right. Can you think of a way to set that right from single user mode? I've already chowned / with root:admin, but the fact that it's authorizationhost making the fuss points to something in the sandboxing protocol (entitlements?) which I know dry little about – Evan Mar 26 '14 at 18:23
  • IF there is nothing valuable, I would suggest reinstalling Mac OS X. You can also try redownloading the Combo update (again. I know, sorry). – PoisonNinja Mar 26 '14 at 21:55
1

In the end, it was a fault being caused by mis-matched RAM. Solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .