6

My iMac suddenly stopped recognizing my WiFi network. Numerous other devices are connected to the same network (2 MacBooks, iPhone and LG Nexus). The network doesn't display in available networks list, but I can see all other WiFi networks available from neighbours. I have tried following things already:

  • Restart iMac
  • Restart WiFi router
  • Add new 'location' in network settings
  • Change radio channels in my router
  • Manually input network SSID, security type and password (it keeps telling me that network with this name doesn't exist)

The iMac sits very close to the router and other devices work flawlessly in the same place. What's worth mentioning is that this behaviour was sudden, that is everything as working fine until it suddenly stopped.

I'd appreciate any help!

  • 1
    Is your iMac able to connect to other WiFi networks, such as a hotspot from your iPhone? – Kevin Grabher Mar 26 '14 at 1:51

14 Answers 14

2

I changed the channel on my router to "auto-select" and it fixed the problem. Ran diagnostics on my iMac and it found "Crowded Wi-Fi Chanel" so this may be the case for you too. Try changing the channel on router or do auto select.

  • Changing the channel fixed the problem for me. I would suggest to choose between channel 1, 6 or 11. – Levani Jan 12 '16 at 18:12
1

I have been having the same problem. Changing the name of the SSID fixes it immediately. But if I ever happen to switch off the router and switch it back on, the problem recurs and I have to think of yet another name.

0

Can you see it if you boot from the recovery partition? Try booting while holding down Command-R.

Once booted, try to connect to the Wifi.

If you can see it in Recovery mode, then it's probably a corrupt system file or cache. If you still can't see it in Recovery mode, I have no idea what the problem is.

0

How about switching off your modem? I think I experienced the same thing - my iPhone and my Mac both began reporting failure on attempting to connect to my WiFi router (Airport Extreme, 2 or 3 years old). Lucky for me I have two Airport Expresses to extend my network, so I still had WiFi. Oddly, I found that one of them, which connects to my router only wirelessly, was still working; the other one was connected via Ethernet and was also fine. After seeing your post here, I aimed Wireless Diagnostics at the main router, but it wasn't able to "diagnose" because it couldn't connect. Trying Internet settings in various devices I got messages to the effect of "this device has no IP address." So I think I may have been having the same problem as you. I recently updated to OS X 10.9.2, but don't know whether that caused the problem. After re-booting all devices & computers, no joy. So I shut things down and did one step you don't list above: I not only unplugged power from the router but also switched off the modem. Left everything off while I started cooking dinner. After about ten minutes I first switched the modem back on, then waited a few minutes and plugged the power cord back into the router. When I restarted the computers and i-devices, everything was fine. Did you try that step of switching off the modem?

0

I have a similar problem with a bit of a work around.. I'm not sure if it works for others and I'm also trying to understand it myself because it is a bit annoying.

My laptop will always see my wifi network but sometimes my wife's MacAir or my moms Samsung tablet will suddenly not be able to see the network. By freak luck I discovered that turning on and then off the MAC filter fixes this problem.

From my laptop, I type in (192.168.1.1) to access my modem and under the wireless settings, I activate and immediately deactivate the MAC filter and then hit save. (If I wait more than 3 seconds to deactivate the MAC filter, then my laptop will not connect and I have to use another device to access the modem settings so be sure to do it quickly.) When I hit save, all devices will be able to see the network.

But this only lasts until the next day, especially with my mom's tablet. With my wife's it can last months before having to do it. It's a workaround for me but pretty annoying.

0

I know this is an old question - but i just encountered same problem. Some one else might, too.

This is what hit me: The iMac sits very close to the router

It's not good for RF devices to sit to close to each other for various reasons

Long story short: I moved the WiFi AP away from mac (it was sitting at it's right side and now it's 2 meters behind it): problem solved.

0

I had same problem with my Mac Mini. I changed network's name and Mac Mini recognized new network. It meant that issue was only with my Mac. I "forgot" this network

(Settings -> Network -> WiFi -> Advanced (OS X 10.10.3), selected missing network and removed it from Preferred Networks)

and connected to my network.

0

I had the same problem, suddenly. Solution? I opened the list of saved networks and removed it, it appeared in the list of networks in range immediately.

0

My mav wasnt able to recognize and wifi networks. The fix is easy. Hold power until late it powers off. Turn it on and when the apple appears on the screen hols shift. It will reboot your computer. Once the computer turns back on you'll be able to see the WiFi networks in range.

0

My MB Air suddenly wasn't recognising any wifi networks but the reboot with shift key solution above worked for me

  • Hmm, you shouldn't have to be in safe mode for it to work. I might recommend submitting another question so we can help fix this. – JMY1000 Sep 20 '16 at 17:02
0

Had similar problem. After resetting the router, the SSID went invisible on my macbook pro, but was visible on my android device. I tried rebooting both laptop and router, and also tried connecting to the network as a hidden network with no success. Finally, after I went into the router settings and changed the SSID, it fixed the problem and the new SSID was immediately visible.

0

If only our MacBook is not seeing the WIFI, the issue may be the "WIFI channel".

If you have access to the router (usually by 192.168.0.1 etc, user name and password printed on the router), use your other devices to manually set the WiFi channel. Do not make it automatic, rather, set it to a small number, say 2.

If you do not have access to the router, you may try to reset your location. It is in the system preference -> language and region. Some location disabled certain channel of WiFi. Hope this could help.

(My old MacBook Air suddenly cannot see my WiFi at my home after I come back China. It turns out my region is still US and US seems to only use channel 1-11, but the router in my home prefer channel 12 &13)

0

Had this problem recently

Here's what worked for me on macOS Mojave

Summary: Create new "Location", switch to it for a few minutes, then switch back to "Automatic" location

  1. Sysprefs -> Network -> Wifi
  2. Edit Locations (Drop down menu at top of network prefspane)
  3. Create new location, "TEST" or call it whatever you want
  4. Apply

Count to 60. This is more superstition than anything else.

Switch back to "Automatic"

WiFi SSID should show up again, even to the point of reconnecting automatically.

-1

I've tried many of the given solutions but they didnt work. I accidentally discovered that if you log in to your phone hotspot that miraculously your home Wi-Fi network appears on the list, after which you can connect to it.

  • Welcome to Ask Different and for making your first contribution. Some friendly advice: avoid writing in 1990's texting vernacular and use proper capitalization, punctuation and sentence structure. Your answer is very likely to not get up voted and may even be down voted. – Allan Jun 1 '18 at 23:37

You must log in to answer this question.

protected by Allan Mar 11 at 14:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .