0

I am unable to access data on mounted volumes in Finder on OS X Mavericks.

Assuming I mounted a volume by plugging in an external USB disk.

What works:

  • The volume is listed in the Finder sidebar
  • I can access (read+write) it under /Volumes/MyDeviceName/
  • I see it being listed properly when calling mount from the shell

What doesn't work:

  • I cannot click on it in the Finder sidebar
  • When I open /Volumes with Finder, MyDeviceName is not visible
  • When I try to open /Volumes/MyDeviceName it says The folder can't be found.

This problem doesn't only occur with external USB devices, but also with TrueCrypt Volumes, etc. I thought it might be an NTFS problem, but it also occurs with other file system types.

I've tried to reset the Finder preferences by deleting com.apple.finder.plist, as per suggestion by other threads, but this has not solved the issue.

  • Try disk Utility and repair permission there for that drive. – Ruskes Mar 25 '14 at 12:39
1

I managed to fix the issue, which appears to have been a bug or incompatibility with Tuxera NTFS driver (which makes NTFS writable) and Mavericks.

I updated the dependency and it worked. This threw me at first, since I also experienced the issue with non-NTFS volumes. Now however, everything works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .