0

I have been having problems with my iCloud account not syncing properly with my iOS devices, so I wanted to reinstall the iCloud account.

The first thing that I wanted to do was to remove my old iCloud account, which worked for everything except for Mail.

When I try to deactivate the iCloud mail setting, it says:

iCloud Mail couldn’t be disabled from the iCloud Preference Pane.

Open Mail and remove your iCloud account from Mail preferences.

However, when I do that, Mail does not have an iCloud account, so it cannot be removed.

Here is what I have tried till now, without success:

  1. I tried to add the iCloud mail account into mail.app so that I could remove it.
    • Adding the account “worked”, as in it didn't fail, however the account still does not show up on my list of accounts, and so still cannot be removed.
  2. I have restarted my computer
    • I didn't expect this to work, and it didn't.
  3. I have repaired disk permissions.
    • There were a few errors (aren't there always??), but this didn't help.
  4. I have searched the web for others having the same problem.
    • I didn't find anyone with the same issue, nor did workarounds for other similar issues help.

In response to the comment on the question. I have a lot of (almost 6000) 'ACL found but not expected' messages. I have been led to believe by various internet searches that these are harmless.

  • @3 - no there shouldn't be any. Paste them, it might be your problem. – Rob Mar 25 '14 at 7:34
  • can you try adding a new account to your Mac and configure a new iCloud account there? – Rob Mar 25 '14 at 9:59
  • @Rob the iCloud account works perfectly on my other computers and iOS devices. It is only on this one machine that it is problematic. – Paul Wagland Mar 25 '14 at 10:08
1

I know this is an old question, but since it was one of the first hits on a google search I thought it could use an answer that worked for me. I had a similar problem to this - I had a duplicate of my iCloud account that I couldn't remove, and I received the same message about having to delete the account in system preferences. Deleting the account from there didn't seem to help, so I was searching for possible solutions, and an answer to a similar question put me on the right track. You can see my description of the fix on that post (How to remove 'phantom' iCloud account from Apple Mail) , but I'll repeat it here:

First, I logged out of iCloud in system preferences, and let it delete all the relevant local copies of iCloud data.

Next, go to the Library folder in finder. You can do this by holding 'option' and clicking the 'Go' item in the menu bar, then selecting Library.

In this folder, go to a folder called Mail. In this folder, you'll find Mail/V2/. In Mail/V2/ there are a number of folders corresponding to the accounts you have added in Mail. It's easy to tell which is which. There's also a folder called MailData - I'm using Yosemite, and the folder MIGHT have a different name/structure in other versions, but regardless of version you should be able to find a file called Accounts.plist.

First I deleted the folders that corresponded to the accounts I wanted to purge. Next, I opened Accounts.plist in a text editor – it doesn't matter which one you use, but your life will be slightly easier if your editor of choice can highlight matching tags in xml type files.

The part you're looking for begins with the following:

<key>MailAccounts</key>
<array>

The next thing you'll see is a <dict> tag. This is the beginning of an individual account 'object'; all information for each account will be between <dict> and </dict> tags. Find the 'block' that seems to correspond to the account you don't want, and delete everything from the <dict> to the </dict>, including the tags themselves. Be careful though, because there's another set of tags nested inside containing info about the vendor of your email account - you want to be sure you're selecting the matched outer pair.

Having done this, I was able to load up Mail again, and the unwanted accounts were gone. The remaining accounts were working fine. I then went back to the iCloud preference pane, logged into my account again, and checked the box for Mail – it worked, and I now have a fully functional iCloud mail account, and no duplicates.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .