1

I have a Mid-2011 13" Macbook Air running OS X 10.9.2 (the latest version). When I wake my Mac from sleep, sometimes, the Wifi will fail to find my network. The network icon will display the connecting symbol. The only way to stop that is to turn off wifi and turn it back on, where it will reconnect almost instantly.

A video I made showing my problem: http://www.youtube.com/watch?v=EtwPg9ff4WE&feature=youtu.be

  • It's happening to me too. I use my MBPr with a desktop setup with external monitor, bluetooth mouse and keyboard. What I found is that this doesn't happen when Bluetooth is turned off, as soon as I turn on bluetooth it starts happening again. I have searched numerous forums, did numerous steps to resolve this but the problem isn't going away. So at this point I feel like this is a bug in 10.9.2 update :( – AnBisw Mar 30 '14 at 1:12
  • I had it on all versions of Mavericks. I also never use Bluetooth, so it's off... – PoisonNinja Mar 30 '14 at 19:49
  • Maybe a different issue, but mine gets resolved as soon as I turn off bluetooth. – AnBisw Mar 31 '14 at 22:31
  • Had similar problem. Solved it by turning off DoS protection on my Wi-Fi router. – Mikhail Vladimirov Apr 25 '17 at 18:05
1

I've ran into this issue recently and solved it by unchecking:

System Preferences > Energy Saver > Wake for network access

See this thread on Apple forums - Wifi disconnects after sleep and takes long time to reconnect with Mavericks

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .