2

Before Mavericks I had a BootCamp dual boot configuration with Lion and Seven x64. That was fine but, because I replaced the hard drive with a SSD model, I took a chance to set as the newest environment as possible. I found out to my sadness that Mac Mini 2010 (model 4,1) is not supported by BootCamp 5 therefore Windows 8/8.1 neither.

But there are workarounds to install BC5 and the other missing (mostly graphic) updated drivers. The problem is to get to that point.

A second aspect is that, even if I have a DVD unit (by the way I own an external one too), don't ask me why, it doesn't read Windows DVD properly, so I decided to go for a pen drive installation, that is possible with another workaround.

So, goals:

  1. Install native OSX Mavericks + Windows 8.1 x64
  2. Complete the Windows installation through a pen drive, not using DVDs

What I did: Modify Info.plist file as it follows:

  • add my Bootrom Version at the top in the "DARequiredROMVersions" section
  • delete "Pre" from "PreUSBBootSupportedModels" that becomes "USBBootSupportedModels" and add my Model Identifier at Top First
  • delete my model "Mac mini 4,1" from the Win70onlymodel

Editing has been done with TextEdit plus XCode4 and thanks to this post.

Cool, now BootCamp assistant in Mavericks has more features enabled, like the possibility of setting a flash drive up to install Windows or prepare a boot device with Windows 8, not only 7.

Because I read that there are some problems to make the hardware being immediately recognized, I decided to postpone that part and not including Bootcamp drivers in the device. The pen drive was set up on a MacBook Retina 2013. After creating a partition (through the assistant), here come the problems. Windows 8.1 installation starts, I'm asked to choose a destination partition but, whatever I do, a message appears and says: "windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks"

I tried to - re-format the disk (I don't see any advanced options by the way, like this) - install rEFIt - use Windows 7 Tools, but it keeps telling that "unit is in use" and I can't reverse the .iso on the pen drive - change the partition table of the pen drive, from MBR to GPT but then I cannot copy the contents of .iso inside then

I don't wanna make an upgrade from Seven and as far as I know Win8 use EFI just like OSX does, so what d'u suggest me to do? Are there any other ways I haven't explored yet or the solution is to re-format the disk again with the GPT file structure, install OSX and then Win8.1

This is the actual partition table is this one:

    /dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS MacOSX                  49.2 GB    disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data Untitled                200.0 GB   disk0s4
  • Reformat the partition that is intended for Windows 8. – PoisonNinja Mar 25 '14 at 0:59
  • already done, the message stands. Other solutions? – DioBrando Mar 25 '14 at 14:18
1

I tried to use virtualbox by enabling it permissions access to my whole drive. This also did not work.

The only available solution, after extensively scanning the web, is to install with the native dvd drive.

However, I am surprised that the community has not defined a better solution. One where one can dual boot windows/ or, bootcamp windows in a macbook 2010 (for example) where the optical drive has been replaced by a second hard drive [without removing the second drive and reinstalling the optical drive]. I am also not satisfied with the cloning a drive option as this too requires removing drives and reinstalling and gaining access to a second mac.

I think that ubuntu (http://www.askubuntu.com/) may be able to define a solution using unix code to fix the problem once and for all!

0

I don't know if this helps but I had a similar problem installing Win8.1 on a second drive in my 2010 macmini server , I just used the Windows Tools avaialble when installing Win8.1 to delete and repartition the drive and format, worked like a charm,

I did boot off a Win8.1 DVD as I hadn't hacked Bootcamp , just hold down option key while starting or restartingand select EFI and Windows boots up nicely.

Hope this helps someone.

Still looking for the correct NVIDIA graphics driver and the USB Bloetooth Host Controller drivers. I tried various Nvidia drivers and just got no video and had to do a restore back to before the install.

Cliff

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .