7

I have installed VirtualBox in order to use Windows 7 as guest on a Macbook Air running Mavericks (mainly to be able to use a printer that has no drivers for Mac). Also, I have installed the Oracle_VM_VirtualBox_Extension_Pack and the Guest Additions, so that now the video settings as well as the support for USB are available. Except that, while the flash drives as well as the printer work, the external HDD drives connected by USB do not.

After un-mounting the external HDDs in Finder they appear only greyed out in VirtualBox system tray.

enter image description here

Adding them as filters in the Settings of the Virtual Machine makes them look selected as they should (no longer greyed out), but they are still not available in the guest Windows.

I am talking about two external HDD drives, both 500 GB, one ntfs and one fat32.

I expected the USB connections to work fully after installing the Extension_Pack and the Guest Additions, but it looks like there's something more to be done.

What?

  • 1
    Do you have ntfs for mac installed ? Make sure you can write on that drive in your host OS first. – user75489 Apr 12 '14 at 3:56
  • @Gulali - No, I have not installed "ntfs for mac" and have no intention to. Isn't that for writing on the drive? I do not want to write, just to read, as I already can do in Finder. What about the fat32 drive? I can read and write on that in Mac's Finder, while in Win7 none of the 2 external drives is accessible. – user61618 Apr 13 '14 at 11:03
  • 1
    Are they connected directly or via a hub. Also there is a setting in the virtual machine settings to give the guest vm direct access to a particular USB device. – Brian Duke Jun 9 '14 at 21:31
6

Once I ejected the hard drive from mac os, it was instantly recognized by the guest windows virtual machine.

| improve this answer | |
1

insert Guest Additions CD image.iso corresponding to your version number http://download.virtualbox.org/virtualbox/ worked for me once I unmounted USB from host OS launched VB, went into settings adding the USB filter and pointed to desired USB, launched VB, logged in to windows, voila, right there in computer devices as Drive (E:)

| improve this answer | |
1

Host: MacBook Pro Summer 2014 with Mac OS Sierra 10.12.6 (has USB 3.0 ports). Guest: Windows 7 Professional 64-bit (I have not installed USB 3 capability yet).

Win7 would not recognise a USB 2.0 Kingston 16GB memory stick. I have VirtualBox extensions installed, and have added a USB device filter under VM settings. I have solved the problem by plugging a USB 2.0 hub into the MacBook Pro's USB 3.0 port, and then plugging the USB 2.0 memory stick into the hub. It works. (I have a Kensington PocketHub Mini USB 2.0 with 4 ports). Likewise I can now use a SanDisk Ultra USB 3.0 memory stick through the USB 2.0 hub.

This also solved a similar problem with an HP-Prime graphical calculator; the HP software on my mac would not see the calculator if it was plugged directly into the USB 3.0 port, but it was fine when I used the USB 2.0 hub.

| improve this answer | |
0

I have an issue maybe related (i do not use MAC at all)...

I can not make VirtualBOX to pass to the Guest a "USB 2.0 Hub"... it is not listed, it is hidden.

Does your USB HDD's have an internal HUB? Some have it... like some WD that also have a VirtualCD.

Maybe it is not related to your problem, but maybe it is.

Another problem i have with VirtualBOX USB redirect is that two USB devices (same name) can not be passed to the Guest at same time... it only pass the first one i try...

I do not know much about MAC, but my experience with VirtualBOX USB redirect is that it fails a lot in some conditions... no matter if host is Windows or Linux... it is VirtualBOX USB redirect what is failing!!! So i think the same will happen on MAC's.

It is just an idea!!!

| improve this answer | |
0

Seems like you'd like the guest system to handle the whole USB thing. Because OSX automatically attaches USB devices, you'll have to do the following:

Open Machine Settings > USB > Click the green plus symbol > Select your HDD. Then unplug the Disk and plug in again, from now on the guest should see it as an USB device.

| improve this answer | |
0

After unmounting your drive in the Finder, try opening Disk Utility, and see if the drive can be ejected. After ejection (if done), VirtualBox may see the device.

| improve this answer | |
0

In my case (OSX Catalina, Virtual Box 6.1 and Windows 10 virtualized), I managed to get it working by using the the Oracle VM VirtualBox Extension Pack.

Get them from the official downloads page. Make sure to download the exact version for the VirtualBox that you have installed.

Afterward, follow the instructions for their installation. In case something happens to that third party site, here they go:

  1. Open VirtualBox.
  2. From the left list, click Tools>Preferences. A window should appear.
  3. From the icons at the top of that window, select Extensions. Click the plus (+) button at the right, browse to the folder where you downloaded the extension, and open the extension package. VirtualBox will notify you that you are about to install an extension pack. Confirm to install. After that, it should appear as active in the list of extension packages.
  4. Make sure that your virtual machine is not running.
  5. Check the settings of your virtual machine (select it in the left list of the main VirtualBox window and click the settings icon at the top) and make sure that in Ports>USB the USB controller is enabled and is using the USB 3.0 controller. If you don't see your external hard disk drive listed at the bottom, add it with the plus (+) button at the right of the list.
  6. Umount (but DON'T unplug) your external hard disk drive from OSX. Start your VM. You should have access to the hard disk drive inside the virtual machine.

This worked for me. I needed to partition an external hard disk drive with a NTFS partition.

| improve this answer | |

You must log in to answer this question.