enter image description here

enter image description here

OK, from the first picture it is a case of internet sharing via wireless is successful. And in the second case on picture two I tried to share internet via wireless by tick off and tick on "Internet Sharing"(again and again) but it doesn't work. I can not share the internet via wireless (notice the red highlight frame the wireless status logo it doesn't change)

what have i tried ?

Sometimes, I could figure out this problem by restart my computer. But do you have the another ways to figure out this problem without of restarting the computer?

i try also many things, but after i change the network name in wifi options in internetsharing its work and i got the arrow back :)

  • Worked for me too on High Sierra 10.13.3 (17D47) – Sridhar-Sarnobat Mar 11 at 3:29

I noticed an Issue in our Company on some of the 2011 27-Inch iMacs were sometimes the Ethernet-Adapter failed.

If your Ethernet Adapter is not connected to the Internet, your Mac won't share the connection via Wireless, because there is no ethernet/internet to share.

You may try it : Plug in the ethernet cable, share the ethernet via wireless. If it starts to share ( like in the first picture ), plug off the cable and watch what happens. I can't reproduce it here, but it will probably change to the grayed icon as seen in picture 2.

Other reason could be a failure of the Router were the internet is coming from. The Sharin panel is simply sharing "Internet Access" so if you are connected to your Intranet ( Home Network ) but not to the Internet (www), then it will also not work like you expect it. The Icon will stay gray, until you are sure you have access to the Internet.

And If you really have Internet Access via the Ethernet Adapter, then there is something wrong with the Mac. You could Try : - Reset PRAM (at start sound press CMD + ALT + P + R) - Reset SMC (press power button for a couple of seconds when the cable is unplugged and the mac is turned of) - Restart the Ethernet Adapter -> go to the system preference pane for the network, click on the ethernet adapter -> go down to the little gear and click on deactivate service, wait a minute, then click on activate service and the ethernet should start properly.

This could happen if the Ethernet Drivers are not working properly and in some cases it can happen, that those crash. I had that Issue on a older Mac Pro that always refused to connect, when I restarted the router and the mac got a new IP.

So there are as always many reasons, that could cause the problem. just comment if you are getting any closer to the problem. Then we are able to help in a more specific way.

  • Sorry @YoshiBotx It doesn't work. In actually. When i tried to thick off and thick of to share the internet the wireless logo will change to arrow(liked a second picture) just a very very short time then go to black and grey in my opinion i think my computer trying to connect to wireless router. and this disturb the sharing process. but thank for your help it's useful. – fronthem Mar 22 '14 at 5:17

It worked for me (Yosemite) just changing the WiFi Name in the Internet sharing settings and then activating internet sharing again.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.