11

In the last few weeks, screen capture stopped working on my MBP. Well, partially.

I can still capture to the clipboard with command + control + shift + 4, but if I try to do a standard capture to a file, my Mac plays the screen capture sound but nothing gets saved on my Desktop.

I'm running OS X 10.9.2. The issue has survived a reboot.

Any suggestions?

  • what is standard capture to a file ? – Ruskes Mar 20 '14 at 22:14
  • 1
    If it makes a noise it took a pic, but the question is where did it save, do a search for "screen"? in finder all my files – Ruskes Mar 20 '14 at 22:21
  • 1
    For me it was solved by relaunching the Finder (option + right click on finder icon in dock and than Relaunch) – Mladen Janjetovic Jul 19 '16 at 9:16
  • I've tried all of the below solutions and none of them are working :( – rofls Nov 9 '17 at 23:25
13

Are you running Dropbox? It has a "feature" that grabs screenshots, copies them to a folder called "Screenshots" in your Dropbox folder and then puts a public URL for the file on your clipboard.

Look for "Screenshots" in your Dropbox folder.

16

None of the answers above helped me, but I discovered the my case:

Shift + Command + Control + 4 saves the screenshot to the clipboard.

Shift + Command + 4 saves the screenshot to a file on Desktop.

So if you're using the first short-cuts, you have to manually open a photo editing app and paste the image, but this can be done automatically with the second short-cut.

9

I've never heard of this kind of issue, but I did some searching and it seems that this should work:

  1. Open terminal
  2. Copy, paste, and enter this line:

    defaults write com.apple.screencapture location ~/Desktop/
    
  3. Copy, paste, and enter this line:

    killall SystemUIServer
    

(See OS X Daily source and Lifehacker source.)

2

It sounds like the file is may be getting saved elsewhere. It can be set with defaults write com.apple.screencapture location ~/Desktop/ and you'll need to killall SystemUIServer or log out/in again for it to take effect. As an aside using type and name instead of location can set those as well. defaults read will tell you how things are set.

  • 1
    The domain/default pair of (com.apple.screencapture, location) does not exist – Michael Nov 15 '16 at 23:08
1

Under system preferences, go to Keyboard>Shortcuts>Screenshots. Check your key configurations and restore default if you need to. You can also try changing it and changing it back.

  • Thanks, but they're all still set to the default. My Mac actually makes the screenshot sound, but it doesn't save the file. Updating my question to clarify that... – Josh Earl Mar 20 '14 at 20:59
  • Do command-shift-3 to save to a file then do a spotlight search for all files named spotlight. The file save location could have been changed some how. You can use something like Onyx to change it back. – traisjames Mar 20 '14 at 21:46
1

Shift, Control, Command, 3 or 4. Copied a screen shot to your clip board. You now need to paste this screen shot somewhere to see it.

If you use: Shift, Command, 3 or 4. This will save a screen shot to your desktop.

This will answer your question. All the best.

1

Your Screenshot is getting saved to the clipboard instead of to a file. Are you using a third party mouse like a logitech mouse? If so then go into the mouse settings and if you are using a shortcut, change the save setting to file instead of clipboard.

1

The answer for this is here, but spread out over several answers so here's everything in one handy place.

Works for these options: - Shift+Command+3 - creates a separate file for each active screen. Basically a file for every monitor attached to your system. - Shift+Command+4 - Allows the selection of an area to capture to a file. - Shift+Command+4 then press space - Allows the capture of an open application window.

Does not work for Control+Shift+Command+4(3) as these key combos put the screen shots into the clipboard.

Open terminal (or your favorite terminal emulation program) and follow the steps below:

mkdir ~/Desktop/Screenshots
defaults write com.apple.screencapture location ~/Desktop/Screenshots
killall SystemUIServer

You can replace the location with something other than ~/Desktop/Screenshots if you prefer. The directory has to exist or you will get an error saying that you do not have permission to save files in the location where screen shots are stored.

0

In the last few weeks, screen capture stopped working on my MBP

This happened to me. Go to Dropbox, Settings, Preferences, Import and uncheck "Share screenshots using Drop Box.

Mine now save to my desktop.

You must log in to answer this question.

protected by Community Feb 19 '15 at 11:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .