11

Is there a way to prevent Chrome from switching to dedicated GPU? But just Chrome. Not the gfxCardStatus way.

rMBP (late 2013)

5 Answers 5

14

I was having an issue with gfxCardStatus not being able to switch to the Integrated Intel GPU because of a Google Chrome Helper task. My mid-2010 Macbook Pro has a bad discrete GPU so of course that is pretty inconvenient. This worked for me:

Go to chrome://settings and set the Use hardware acceleration when available option to off:

Put this in the omnibar to find this setting easily:

chrome://settings/?search=hardware

1
  • Thanks for this. You've saved me a long time dilemma.
    – ken4ward
    Commented Mar 10, 2020 at 9:42
7

I found this to work for me chrome Settings > Advanced > System > uncheck "Use hardware acceleration when availableenter image description here"

3

This might help you :

chrome graphics acceleration

Type about: flags in the address bar and hit Enter button. Now locate the following three options and disable them.

  1. GPU accelerated compositing

  2. GPU Accelerated Canvas 2D

  3. Web page Prerendering

4
  • These settings are missing on the latest version of Chrome.
    – Dzh
    Commented Apr 6, 2015 at 10:23
  • 1
    I can confirm disabling all the features mentioning "gpu" in about:flags solved my battery draining when the MacBook Pro 2016 was sleeping
    – SDReyes
    Commented Dec 1, 2016 at 13:52
  • @Dzh: these settings are still there on Chrome 86.0.x ; the 3. "Web page Prerendering" settings have changed somewhat
    – smci
    Commented Nov 16, 2020 at 4:25
  • 1
    Unsure, but there's an OS level setting now sudo pmset -a gpuswitch 0
    – Dzh
    Commented Nov 16, 2020 at 22:01
2

On newer versions of Chrome, most of these are missing, however, this one still remains: chrome://flags/#disable-accelerated-2d-canvas

Turning this on, however, still lets the dedicated GPU to be used when WebGL is accessed. I'm looking for ways to disable this behaviour (I have a dead AMD GPU on my MacBook) but haven't had luck as yet.

1
  • Same here, neither of the settings helped.
    – Dzh
    Commented Apr 6, 2015 at 10:23
0

use gfxCardStatus to lock your discrete card and no program will be allowed to access it. It can also force your discrete card to always be on if you prefer.

2
  • The question asks for "just Chrome. Not the gfxCardStatus way."
    – John N
    Commented Feb 3, 2017 at 18:58
  • 2
    In some cases gfxCardStatus does not prevent switching
    – Vasfed
    Commented Feb 15, 2017 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .