From time to time my Drafts folder contains an autosaved message that I haven't sent which is nice because I can pick up where I left off creating a new message, but lately most of the messages are messages that I did send.

I then have to go and check that the message did in-fact get sent before I can delete the draft.

This mailbox is unified from 3 IMAP accounts, one being a gmail account. I haven't seen a pattern (e.g. the zombie drafts always being from one account).

Has anyone else fixed this issue, or at least seen it?

  • 1
    Back in Snow Leopard, I remember suffering from this and it was one of the reasons why I stopped using Mail.app. I haven't really used Mail.app since, but I do remember this from long ago.
    – grg
    Commented Mar 18, 2014 at 20:48
  • This happens to me too using POP3 on OS X 10.9.
    – berliner
    Commented Jul 15, 2015 at 22:37
  • Yes this is happening to me on icloud mail with up to date software on all devices. The drafts are on the other devices and not the one the email was sent from.
    – user185878
    Commented Jun 2, 2016 at 22:26

1 Answer 1


Gmail accounts are specifically subject to this issue.

In this Apple Support Communities post, there is a good discussion of why this occurs and how to reduce or stop it. To quote a particular response:

Mail creates a temporary draft each time you compose a message. If you send the message while the IMAP account syncs, the draft doesn't get deleted and gets stored in gmail's draft folder.

If you want to stop this, uncheck to store drafts on the server. It will put the draft folder back under the gmail folder and create a local draft folder for gmail. If you need to complete a draft on another device, simply move it to the IMAP draft folder.

I can verify from experience that this issue occurs in Mountain Lion as well.

  • 2
    Still a issue in Yosemite, Apple should absolutely fix this.
    – tholu
    Commented Mar 3, 2015 at 20:08
  • heh, for some reason this box became checked again. Took me a while to realize that and find this question/answer.
    – dwightk
    Commented May 16, 2015 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .