3

I have a Ubuntu guest running on my Windows 7 host. I then wanted to connect remotely from my Macbook Air in bed, and so accessed the VM via Microsoft's OSX remote desktop client. I'm able to successfully connect to the Ubuntu guest VM, however my Macbook Air's arrow keys output numbers when pressed making it impossible to navigate with them (a big problem for coding).

Additionally, the touchpad is hyper-sensitive when using two fingers to scroll on the page.

I found a random forum post suggesting to turn off Numlock on the Windows host machine which I did, however nothing changed (even after rebooting the VM and reconnecting).

How can I fix the arrow keys so they function as arrow keys?

  • What do they actually do? What numbers do you see with what key? – Rob Mar 18 '14 at 8:53
  • Left=4, right=6, up=8, down=2. And to clarify further, I've tried going into the Ubuntu keyboard settings on the guest, and the Windows host numlock key does in fact toggle the numlock key in the guest. However if I turn off numlock, and then hit an arrow key on the Macbook while remotely connected, it instantly turns on numlock and inputs a number. – Haltingpoint Mar 19 '14 at 5:39
  • I've searched all over and tried everything, and I can't figure this out either. – vcardillo Apr 3 '14 at 20:58
  • Bumping this thread. The problem also presents in Windows 7 and Windows 10 guests with 10.10.4 host. – Allan Jul 22 '15 at 15:42
1

The problem is that the NumLock state gets stuck to On inside the RDP client. Tools like numlockx don't help - the client returns the state back to On. It's not just the allow keys that stop working - Ins, Del, Home, End, PgUp and PgDown are affected as well. The solution I found is to remove all references to keypad keys affected by NumLock from the xmodmap settings. To do that, run on the guest

xmodmap -pke | sed 's/KP_\([^ ]*\) KP_.*/\1/' > $HOME/.xmodmap

.xmodmap will be loaded on the next login. To load it immediately, run

xmodmap $HOME/.xmodmap

Alternatively, use the newer version of the RDP client (Microsoft Remote Desktop 10). It fixes the arrows. It's a full rewrite of Microsoft Remote Desktop, it has its own issues with the Insert key and middle mouse button.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .