I recently purchased a CSR8510 A10 based Bluetooth 4.0 (Bluetooth Low Energy aka BLE) dongle and I'm using it on a mid-2011 iMac that doesn't have Bluetooth 4.0 support. Just plugging it in doesn't appear to work, the CSR8510 A10 device appears in the USB device tree, but there is no indication of Bluetooth functionality.

To diagnose the problem I run the LightBlue OS X app and on launch it displays a dialog with the "Turn Bluetooth ON" message and "Press Done when it is on". If I push the "Done" button it just displays the dialog again. So it appears that it sees the device, but it isn't initializing.

Is there a way to get this device working?


I tried the instructions here mentioned by dwightk, but they don't appear to be effective.

I also tried the instructions here, but they don't appear to work either.

Note: When checking the CBCentralManager.state the value CBCentralManagerStatePoweredOff is returned.

  • 1
    There is a convoluted process that requires using Windows software to change the devices bootmode that might be worth checking out here: osx86.net/topic/… – dwightk Mar 19 '14 at 15:04
  • @dwightk I just tried following that procedure and as far as I can tell it didn't work. – ThomasW Mar 22 '14 at 16:13
  • sorry man, looks like this one might not get answered any time soon @thomasw – dwightk Mar 29 '14 at 16:20

Oh snaps, I'm going to make you happy @ThomasW.

Okay so after you do the HCI bootmode thing? You also need to whack /Library/Preferences/com.apple.Bluetooth.plist and bounce your system.

If you have both internal Bluetooth and this adapter you may also need to use Apple's "Bluetooth Explorer" (via developer.apple.com no ADC subscription required, get the "Hardware Tools" bundle) and pick a different device.

Just got this working tonight via the change to bootmode and subsequent removal of the existing plist and my Magic Trackpad is totally happy, will test other devices later, it's been a long evening.


I can confirm my CSR8510 A10 based dongle (branded Sitecom model CN-524) is working on an early 2011 MacBookPro8,2. I applied the method described here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .