3

In the past 7 days I have updated to Xcode 5.1 seven times!

Yesterday I dragged Xcode to the trash and emptied the trash in an attempt to make it stick, this morning I got a popup saying that Xcode had been auto updated (should it even do that?) EDIT it is a preference setting!) but there is still an update showing Xcode 5.1 as being available.

I have now dragged Xcode to the trash, emptied the trash, rebooted and fixed permissions. Noting the previous thread about repeated updates I have enabled the App store debug menu and cleared cookies and reset the application. In desperation I even shutdown my NAS which has the old version of Xcode on it (I invoke Time Machine manually)

I am trying to resolve an issue with my ISP and this is not helping. Before I install Xcode for the 8th time, is there anything else I can do to convince the App store that it has indeed updated Xcode?

EDIT: Despite the above preparations, I updated Xcode just now and another update is already showing as being available!

EDIT: I may have solved the problem. Another application needed updating and then also exhibited the repeated download issue. Reading around I discovered comments about Spotlight and App Store issues. The Spotlight fixes didn't seem to do anything for me but I read a comment that deleting some dubious looking files in "/Library/Application Support/App Store" seemed to do the trick. I moved these 3 files to a temporary directory and rebooted. At last! The problem seems to have been fixed. 2 of the files were recreated, the 3rd (utd.plist) wasn't. I will leave it for a few days before declaring success.

  • Have you tried not deleting Xcode? – dwightk Mar 17 '14 at 13:32
  • 2
    I had not deleted Xcode the first 6 times! – epo Mar 17 '14 at 13:49
1

I was having the same problem with the Xcode 6.0.1 update continually showing up in the App Store. I applied the same update several times during my troubleshooting, even though during the process I kept deleting Xcode from my hard drive, I have no need for it any more. I didn't have more than one copy of Xcode on my drive, one possible reason for this issue.

I just solved my problem. I had disabled Spotlight indexing a while back, on the advice of a web page I had seen, because it was using too much CPU and I didn't believe I really needed it. What I didn't know was that the App Store depends on the Spotlight indexes to determine whether you have an app installed; it was looking at a stale index.

I just re-enabled indexing ("sudo mdutil -i on /"), and as soon as Spotlight actually started re-indexing, the App Store decided I didn't have any updates to be applied for Xcode.

0

Install Mavericks again via the AppStore, it won't touch your personal files. It seems like something in your system is wrong pushing you all updates all over and over again.

0

I would uncheck "Download newly available updates in the background" in System Preferences > App Store and not click the update button or whatever you are seeing in the App Store.

This isn't really a full fix, but will at least might help you with your ISP for the time being.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .