3

I have a specific Mac mini server that does not send out email alerts, even though I have an email address configured.

I also want to note that I am not using the mail server within server.app. I have other servers that are sending email alerts correctly and none of them have the mail server within server.app turned on.

Questions:

1) Do I have to enable Apple Push notifications and configure an Apple ID for this to work?

2) Do the email alerts go through Apple's servers after step 1 is configured above, or do they come directly from my server?

3) If they come directly from my server, can I specify a relay host to go through my ISPs SMTP gateway?

4) Is there any way to generate a test alert to test whether this is working or not? What is happening is that the disk on this server is filling up and I am not getting any notifications. It only happens once every couple of months, so I am never sure when it is going to happen.

  • So what you really want is to have a message when the disk size reaches certain limit. – Ruskes Mar 17 '14 at 16:03
  • That's correct. The alerts are showing up in the server.app panel under alerts, however, they are not getting emailed, even though I have setup an email address under alerts \ gear \ configure email address. – David Killingsworth Mar 18 '14 at 2:46
2

I've come up with my own answers for this in case anyone comes across this question.

1) No, you do not have to enable Apple Push notifications.

2 & 3) You can configure them to go through your ISP's SMTP gateway with the following steps (for 10.7.x and 10.8.x).

  • Go to Server.app
  • Go Mail
  • Check "Relay outgound mail through ISP"
  • Click edit to the right of that checkbox
  • Specify your ISP's SMTP gateway in the "Outgoing Mail Relay" field.
  • Specify SMTP relay authentication if required. Click OK.

4) Use the command line shell to issue this command:

echo hello | mail -s TESTSUBJECT youremail@yourdomain.com

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .