0

If I wanted a horizontal rule, I'd type a string of em dashes. I can't find easily a way to disable this over-feature in TextEdit prefs ('Text replacement' is unticked) nor System Prefs ('Correct spelling automatically' is unticked). Thanks!

0

In the Edit menu, go to Substitutions, and uncheck Smart Dashes.

5
  • That does not work as OP said.
    – Ruskes
    Mar 17 '14 at 10:59
  • That is not what OP said. OP specifically talked about "Text replacement"; however, unchecking this is not sufficient as you need to uncheck "Smart Dashes" too. Once "Smart Dashes" is unchecked, everything works as expected (verified on 4 Macs so far).
    – Mathieu
    Mar 17 '14 at 14:35
  • Then bring that in your answer
    – Ruskes
    Mar 17 '14 at 14:48
  • Thanks, that solved it. I dislike how TextEdit puts these things (spelling/grammar too) in both app prefs and the View menu. I rarely remember to look in the latter, and I get such mixed results based on whether an option is ticked in one place but not the other.
    – 2540625
    Mar 17 '14 at 23:52
  • Apparently not all apps have an edit > substitutions menu. iMessage however is one of the apps that does. Had to untick Smart Dashes there despite the fact that the system-wide setting already had this unticked in System Preferences > Keyboard > text (10.11.4)
    – Matijs
    May 17 '16 at 10:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .