55

After starting up my newer iMac it's asking for for the login keychain password for several applications. It is stuck in a cycle that I can't cancel out of. Any suggestions?

36

It sounds as an issue either with the Keychain App. Try repairing it. To do so just:

  1. Locate the Keychain Access application, under /Applications/Utilities.
  2. Choose Keychain Access > Keychain First Aid.
  3. Enter your User name and Password.
  4. Select Verify and click Start.
  5. If any problems were found, select Repair and click Start again.

It could be, too, that you've changed your account password without using the Accounts Preferences pane. If that is the case, for your default keychain to be unlocked automatically when logged in, you'll have to Synchronize your Keychain Access and login passwords. To do so just:

  1. Open Keychain Access.
  2. From the Edit menu, choose Change Password for Keychain "login."
  3. Type the former password of the account that you are currently logged in to, then click OK.
  4. If you entered the correct password, a new window appears; enter the original password again in the Current Password field.
  5. In the New Password field, type the password that matches your current account password.
  6. Re-enter the newer password in the Verify field, then click OK.

This is needed because, as Apple explains it:

If you change your account's password using your Mac OS X Install disc (or if your network-based account password is changed due to a network admin forcing a password change), your default keychain password (which uses the same initial password as your user account) does not change. Because of this, you will be prompted to enter a keychain password each time an application requires authentication that your keychain would normally provide.

  • 2
    When changing the password for the login keychain, I had to enter my old password in the initial dialog, then my new password in the Current Password field. – titaniumdecoy Jun 1 '15 at 22:12
  • 9
    Where to find this option "Keychain First Aid" in order to run a repair? I don't find it in the Keychain Access app. I'm on El Capitan, Keychain Access Version 9.0 (55171.20.2) - seems to be of 2014. Is above description still valid? – Mathias Conradt Mar 17 '16 at 16:52
  • 1
    @Thecafremo Sorry, maybe I'm blind, but I don't see it, this is my menu: snag.gy/nwMon.jpg Mentioned keyboard shortcut isn't doing anything. – Mathias Conradt Mar 17 '16 at 17:07
  • 3
    @MathiasConradt Hum, apparently it was removed with OS X's 10.11.2 update, as described here. Which reminds me that I've got some updates to perform. – Thecafremo Mar 17 '16 at 17:14
  • 1
    The Apple assbandits removed First Aid, I've had this problem on every macbook ever in every company I've worked for when company policy have prompted me to change passwords. So annoying that the Apple idiots didn't fix such a fundamental problem. I have to enter every password I've ever used multiple times until the dialogs go away :@ – Dominic Dec 14 '16 at 10:52
13

I had the same problem. It has bothered me for several weeks on my new Mac. It should be caused by changing Mac password using 3rd party software. On macOS El Capitan and Sierra, there is no Keychain Access > Keychain First Aid. Changing login keychain's password does not help. To solve this problem, you have to reset your default keychain.

  1. Open Keychain Access, which is in the Utilities folder of your Applications folder.
  2. Choose Preferences from the Keychain Access menu (or Cmd,), then click the Reset My Default Keychain button in the preferences window. After you enter your new password (same to the password of your Mac account), Keychain Access creates an empty login keychain with no password. Click OK to confirm. (If you don't see a Reset My Default keychain button, close the preferences window and select the “login” keychain from the left side of the Keychain Access window. Press the Delete key, then click Delete References.)
  3. Choose Log Out from the Apple menu to return to the login screen.
  4. Log in to your account. Your account password and login keychain password now match.
  • 6
    This is fairly unacceptable, as you lose the entire keychain. – Ascherer Sep 11 '17 at 1:57
  • 1
    @Ascherer Correct. All keychain will be reset (removed). But I don't think it is unacceptable. You just need to re-enter some passwords once again. No need to be bothered by the repeated prompt for login keychain password. – Vince Yuan Sep 12 '17 at 2:43
  • "some passwords" isn't really fair. – Ascherer Sep 14 '17 at 5:02
9

Another possible cause of the problem might be the setting "Lock after x minutes of inactivity". Try checking it and if you can live with it, disable the timeout. Keychain Settings

  • Where is this dialogue? – lfk Mar 15 '18 at 23:29
  • 1
    @lfk Open the keychain, then right click of the login keychain and click "Change settings for the keychain "login"" – Carlo Mar 16 '18 at 14:04
2

You have 2 Options:

One is to just open the keychain at log in and leave it open - this is not recommended

2- open keychain find the application(s) in question and give them access

see example

you have to select the Allow all applications to access this item

enter image description here

  • 2
    I tried above - the second option. When I want to save the changes after selecting "Allow all...", I am getting asked for the keychain password, and even there, after typing the correct password, the dialog won't go away and keep asking me for the password over and over. The password is definitely correct though. – Mathias Conradt Mar 17 '16 at 16:58
  • I've just described it in a separate post: apple.stackexchange.com/questions/231340/… – Mathias Conradt Mar 17 '16 at 17:36
1

There is a bug that is affecting some users which is related to this. You may see the colour wheel of death when you get the certificate trust prompt from some applications, like Microsoft Remove Desktop of Microsoft Office (weird but it happened only with these to me!)

Once you see the colour wheel, your only change is to reboot and after this you will get several prompts for keychain password BUT you would have to type your old password even if you previously reconfigured Keychain Access to use the same password.

0

You need to create a new keychain if admin has changed your password.

Per a deleted Apple Support article:

The keychain password is available only to the user and not the administrator. If the login password is reset by the administrator, the keychain password is not changed. The user is asked to reset the keychain password during the next login. If the login password was reset because the user forgot the old password, the keys, passwords, and other information in the keychain won’t be accessible, and the user will need to create a new keychain.

Also here and here.

0

I came across this same issue on El Capitan, and had already searched and tried all suggestions on here.

My solution was to disable FileVault under System Settings > Security & Privacy and everything works fine again.

Update:

Before you downvote because you can't understand how someone can disable the default FileVault encryption: I don't see the downside of disabling FileVault. For really sensitive data, other tools such as Symantec Drive Encryption / PGP or TrueCrypt can be used. At least it doesn't get in the way like FileVault does with the system keychain.

As mentioned in the comments, I had searched on SO for this questions and found several answers, of which none worked for me. Therefore disabling FileVault (and switching to another, independent encryption tool for the data you want or need encrypted) is a viable option.

Advantages vs disadvantages with using file vault.

  • 1
    While this may have solved the problem, the solution has some obvious drawbacks... – nohillside Mar 22 '16 at 8:58
  • @patrix Maybe some drawbacks, but on the other hands, what's a mechanism worth that does not work properly or breaks other parts. You could still use PGP Whole Disk encryption (Symantec Drive Encryption) and achieve the same. – Mathias Conradt Mar 22 '16 at 9:05
  • 1
    @patrix Which ones? I tried quite a few that I found here on SX. See apple.stackexchange.com/questions/231340/… – Mathias Conradt Mar 22 '16 at 13:36
  • 1
    I don't see the downside of disabling FileVault. For really sensitive data, other tools such as Symantec Drive Encryption / PGP can be used. At least it doesn't get in the way like FileVault does with the system keychain. – Mathias Conradt Jan 18 '17 at 8:08
  • 1
    Ok, understood, although I don't see it this way. It's like Windows users using Thunderbird and Firefox or Chrome instead of Internet Explorer and Outlook, totally understandable :). Just because FileVault comes with OS X, it is not necessarily the best solution, even though it comes integrated :) – Mathias Conradt Jan 18 '17 at 8:44

You must log in to answer this question.

protected by Community Jan 3 '15 at 2:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .