3

Since I’ve upgraded to Mavericks (10.9, then 10.9.1), the system has been asking if iTunes (up to the current 11.1.5) should accept incoming network connections every time it launched it.

I’ve tried reinstalling the app, to no avail. Running the app on a fresh account (hence with default preferences and empty library — does it even need inbound connection by default?) doesn’t display the dialog.

I’ve tried removing the preferences file and the iTunes directory from the ~/Library folder, yet again with no result.

I’ve check the signature of the app with:

$ codesign -v /Applications/iTunes.app
/Applications/iTunes.app: a sealed resource is missing or invalid

It thus seems I have an app signature issue.

What should I try next?

  • By way of comparison, this is what I got from codesign -v --verbose && codesign -d --verbose: /Applications/iTunes.app: valid on disk /Applications/iTunes.app: satisfies its Designated Requirement codesign -d --verbose /Applications/iTunes.app Executable=/Applications/iTunes.app/Contents/MacOS/iTunes Identifier=com.apple.iTunes Format=bundle with Mach-O universal (i386 x86_64) CodeDirectory v=20100 size=131865 flags=0x0(none) ..etc.. So yes that's evidence that your app is at fault. Clutching at straws: try disk utility - repair file permissions? – Chris F Carroll Mar 16 '14 at 21:18
3

I reinstalled iTunes again, and this time was successful.

  • It happens when you or 3rd party apps modify iTunes packages. You shouldn’t remove anything anything (like localizations) if you don’t want iTunes prompting to request Incoming Networks Permission. – sayzlim Mar 17 '14 at 9:30
  • 1
    @sayzlim I don’t remember doing any of these things, nor can I remember any reason why I might have wanted to do so. And I installed Mavericks on a brand new hard drive (well, I had to install a Snow Leopard to download Mavericks). – Édouard Mar 17 '14 at 10:10
  • Do you use any apps that free up space by removing useless binary content/localizations? That’s usually the culprit behind this behavior. – sayzlim Mar 17 '14 at 10:16
  • Don’t think so, new hard drive, plenty of space. I’ll try diffing the current app with my Time Machine backup when I get back home, for curiosity’s sake. – Édouard Mar 17 '14 at 10:21
  • Well, Mac OS won’t let me do that right out of the box, and its not worth fighting for it. – Édouard Mar 17 '14 at 23:00
0

Did you have enable the firewall in System Preferences ? ("System Preferences > Security ..")

If yes I think the problem if there. You can disable it or if you want to keep it active you can click on "Firewall options" and manually add iTunes and "allow incoming network connections". Then click on "OK".

  • Yes, the firewall is activated, and iTunes is already listed there. – Édouard Mar 16 '14 at 21:05
0
  • Go to System Preferences > Security & Privacy > Firewall
  • Click on lock in the bottom left corner to make changes and enter your password
  • Select Firewall Options
  • Uncheck block all incoming connections

Lastly, you can add iTunes by clicking the plus sign below the white rectangular box (where you can adjust specific applications' privileges) and then setting it's permissions to "Allow incoming connections".

Or if it is already there, make sure the permission setting next to it is set to "Allow incoming connections".

-1

First, I quit iTunes, then I went into Firewall Options. iTunes was already there and listed as allowing connections. I deleted it by clicking on it and then clicking on the minus sign. Then I started iTunes again. No more annoying message. I looked in the Firewall Options, and iTunes was there again -- it must have added itself.

  • Ugh. I was wrong. I'm still getting the message. – friend Jul 14 '15 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .