I update to the newest 7.1 yesterday. Now some of my apps will not open. Is there a way to delete this update?

  • 2
    Which apps don't run? And did you try to update the apps already?
    – nohillside
    Mar 16, 2014 at 13:36
  • I am having the same problem. It is with iOS 7.1 and not with the apps.
    – user73257
    Mar 17, 2014 at 0:47
  • It isn't clear, do you want to roll-back to a previous iOS?
    – dwightk
    Mar 19, 2014 at 15:24
  • It's not possible to undo an upgrade in general. Let's see if you want to edit this if you have in fact jailbroken your device or if you want to steer this towards how to troubleshoot things. Any edit of the post will cause it to get reviewed for reopening.
    – bmike
    Mar 19, 2014 at 15:56

4 Answers 4


Try shutting down all apps by double clicking the home button, then swiping all of the apps up to the top of the screen to quit them then reboot your phone by holding down the Home & Power button at the same time until it prompts you to shut down.

Go ahead and restart it again. If it still won't fully launch, you may have gotten a bum download. To delete the app, tap and hold on the icon until the 'x' appears and tap that 'x'. Go back to the app store and then reinstall the app and give it another try.


No, unless backing up to a file without this update, for example a backup on your PC. The best thing you can do is unistall those apps (Holding your finger on the app, until the start to shake, then with the cross on the right top the application or via Settings). And reinstall. If this won't work it'll probably be an error in the application, and probably soon fixed by the developer.


This happened to me too, my password manager app "Keeper Data Vault" crashes immediately every time it's opened. Worked fine prior to 7.1 update. And since the makers of this app have abandoned this version and replaced it with a new version which forces you to sign up and give them money regularly, I'm not hopeful of recovering my passwords.

If only I could roll back to iOS7.0, recover my passwords from Keeper and then find a better password manager app that doesn't cheat and rip-off its customers.


The Facebook app didn't work after this update on my iPhone 4, but after I re-installed the app it worked.

Try deleting your app and re-installing it.

Not the answer you're looking for? Browse other questions tagged .