1

I am facing a strange situation on my MacBook Pro. I'm serving a file via http (whatever server I use, I get the same problem: apache, node.js, ...): [http://localhost:8080/myFile] with my wifi adapter:

  • MBP (model 15-inch, Mid 2012, MacBookPro9,1).
  • AirPort Extreme (0x14E4, 0xF5), firmware version Broadcom BCM43xx 1.0 (5.106.98.100.22)
  • When I try to download the file via [http://localhost:8080/myFile] or via [http://127.0.0.1:8080/myFile], it works flawlessly.

  • Now when I try to access the same file, but this time via my local ip and from my machine [http://192.168.1.5:8080/myFile], the download starts but stalls after ~60kbytes ! This happens, no matter which file I serve, and no matter which server technique I use. I tried downloading with browsers (safari, chrome, firefox) and using command-line tools (wget, curl), and I always the same problem...

  • Now, if I try to download the same file, using the same URL (i.e. the one with my local IP) but this time from a distinct computer, it works perfectly again... I am puzzled.

  • Even stranger, if I try to do the same experiment, but this time with my ethernet adapter (and switching off my wifi adapter), I have absolutely no problem... meaning I can serve and download the file as expected, using either localhost or local ip url. So this issue seems to be related to my WiFi adapter.

I do not have any kind of firewall/little snitch/... installed and I checked my WiFi adapter configuration, there is nothing special there.

I tried turning off and on the wifi adapter, shutting down and restarting my mac, everything in vain.

In summary, I cannot download a file that is served locally via my WiFi adapter... But I can download it from a remote machine or using the local loopback (localhost, 127.0.0.1)

Any suggestion about why this might happen / how to push the diagnosis further / how to solve the issue?

  • It ONLY happens from that MacBook Pro, correct? If you use another machine to download via wifi it works fine? – Kevin Grabher Mar 16 '14 at 19:10
  • @kevin Exactly! And any other activity with the wifi of this MacBook is perfectly fine... – pbr Mar 16 '14 at 20:57
  • When you say it stalls after 60KB, does it work with a smaller file? It's possible that your wifi adapter can't upload and download at the same time, but I don't know if that's true. – 0942v8653 Mar 19 '14 at 11:48
  • For smaller files it works indeed. With a bigger file, if I wait long enough, a second block of about 60k is downloaded... Long enough meaning several minutes... – pbr Mar 21 '14 at 9:46

You must log in to answer this question.

Browse other questions tagged .