Sometimes, when I connect an external set of headphones/speakers, I am unable to change the volume. When I press one the volume keys, I see the image below.

Why does this happen? Interestingly, if I am playing music using software that has a volume control (e.g. Spotify or Youtube) I can still change the volume with the mouse using the application's volume bar. However, the system's volume bar is greyed out and can't change it either.

enter image description here

  • 3
    This icon appears when the external device or application has taken over and is to be used to adjust volume.
    – Ruskes
    Commented Mar 16, 2014 at 0:26
  • Thanks @Buscar웃 Is there any way to override that? Why does it have to be one or the other? YouTube and Spotify retain their volume controls, and in many systems the final volume is usually the product of any intermediary volumes. Why can't the system volume be yet another intermediary volume? Commented Mar 16, 2014 at 0:31
  • see my answer below
    – Ruskes
    Commented Mar 16, 2014 at 0:34
  • In case you have an external device that does not support software volume adjustments: Download the latest release of Soundflower github.com/mattingalls/Soundflower/releases and open soundflowerbed (in the app folder under soundflower). Map the external device to the 2 channel soundflower output device and use soundflower 2 ch as output device in OSX. There you go: you can now adjust sound via volume keys for a device that usually not supports this ;)
    – Bijan
    Commented Nov 1, 2015 at 20:16

11 Answers 11


This icon appears when the external device or application has taken over and is to be used to adjust volume.

That also means the internal speakers are disabled.

To verify, go to system preferences sound, and look in the output tab which device is to be used to adjust volume.

See following example

If I select the Sharp TV I will get the icon like you have if I try to adjust volume on may mac, so i have to use the TV volume adjustment.

However if i select Internal speakers the volume adjustments works on my mac.

volume adjustment device


What worked for me: open up a Terminal window and run:

sudo killall coreaudiod

You may also need to run the following two commands right after:

sudo kextunload /System/Library/Extensions/AppleHDA.kext 
sudo kextload /System/Library/Extensions/AppleHDA.kext
  • 2
    Awesome, worked for me! Commented Dec 2, 2014 at 9:30
  • 1
    Worked for me too!
    – hfossli
    Commented Jan 23, 2015 at 20:34
  • 13
    After killing coreaudio I also did: sudo kextunload /System/Library/Extensions/AppleHDA.kext sudo kextload /System/Library/Extensions/AppleHDA.kext
    – Neil
    Commented Mar 3, 2015 at 22:01
  • 4
    I had to restart Spotify after applying this fix but it worked. Thanks!
    – user122297
    Commented May 10, 2015 at 3:06
  • 4
    Funny how this still happens one year later. Running Yosemite here. Thanks for the help. Commented Jun 17, 2015 at 8:47

Simple Hack: Plug in a pair of headphones, then unplug them. This will allow you to control the volume again.

  • 1
    This worked fine for me
    – Vitor M
    Commented May 6, 2015 at 15:25
  • 1
    This is not working for me; interstingly, i jsut started getting this behavior when plugging in the same headphones i've been using for a year, and sometimes it now stays in this mode after unplugging the headphones.
    – Vynce
    Commented Oct 20, 2015 at 7:19
  • 5
    I tried the sudo killall coreaudiod approach, and that didnt work - this did!
    – Brad Parks
    Commented Apr 27, 2018 at 12:12
  • This doesn't work
    – dialex
    Commented Aug 20, 2022 at 13:59

I think I found a quicker and easier fix. At least it works for me.

When the volume keys don't respond (happens pretty often and I haven't figured out why) I simply put the computer in sleep mode then re-awaken it. Takes a few seconds but it works every time.


If all else fails, open a terminal window and type the following to adjust it your volume:

sudo osascript -e "set Volume 5"

You can change to "5" to a higher or lower number to make the volume go up and down


This happened to me too I just shutdown the mac and turned it on again, after this it was back to normal.


I just plugged an audio device back into my macbook air, worked. didn't need to put to sleep or do some code or restart.

  • Interesting the most simple yet effective advice. This immediately worked for me too.
    – JGallardo
    Commented Nov 11, 2015 at 21:56

I tried all the other answers (enabling the internal speakers, killing coreaudiod, putting the computer to sleep), but the only thing that worked for me was a reboot.

I also read somewhere that rebooting into safe mode might fix it, but thankfully I didn't need to do that.


The easiest way to fix this when it happens to me (usually when I unplug my headphones) is:

  • Go to System Preferences -> Sound
  • Adjust the slider bar at the bottom where it says "Output volume".

Even a small adjustment to the aforementioned slider bar re-enables the keyboard volume controls for me.

The question I actually want answered is why the problem happens in the first place. Please let me know if anyone finds out.

  • Regarding why it happens in the first place: I came across this video, which seems to indicate that the headphone jack still thinks the headphones are plugged in. youtube.com/watch?v=lILTI3jpnEE Seems like a hardware problem.
    – Nate
    Commented Aug 21, 2017 at 20:44

I just rebooted and it worked for me! Been having this trouble since I did the last round of updates.


I had this problem twice within this week, first time it happened.

I checked the settings but did not have any other audio device connected. Tried putting my computer to sleep and waking it again, tried quitting the sound applications and started it again, all didn't work.

What worked was I adjusted the volume in the settings by dragging the volume bar manually and I was able to use my volume buttons again.

Kinda annoying.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .