116

Sometimes, when I connect an external set of headphones/speakers, I am unable to change the volume. When I press one the volume keys, I see the image below.

Why does this happen? Interestingly, if I am playing music using software that has a volume control (e.g. Spotify or Youtube) I can still change the volume with the mouse using the application's volume bar. However, the system's volume bar is greyed out and can't change it either.

enter image description here

  • 1
    This icon appears when the external device or application has taken over and is to be used to adjust volume. – Ruskes Mar 16 '14 at 0:26
  • Thanks @Buscar웃 Is there any way to override that? Why does it have to be one or the other? YouTube and Spotify retain their volume controls, and in many systems the final volume is usually the product of any intermediary volumes. Why can't the system volume be yet another intermediary volume? – Amelio Vazquez-Reina Mar 16 '14 at 0:31
  • see my answer below – Ruskes Mar 16 '14 at 0:34
  • In case you have an external device that does not support software volume adjustments: Download the latest release of Soundflower github.com/mattingalls/Soundflower/releases and open soundflowerbed (in the app folder under soundflower). Map the external device to the 2 channel soundflower output device and use soundflower 2 ch as output device in OSX. There you go: you can now adjust sound via volume keys for a device that usually not supports this ;) – Bijan Nov 1 '15 at 20:16

11 Answers 11

165

What worked for me: open up a Terminal window and run:

sudo killall coreaudiod

You may also need to run the following two commands right after:

sudo kextunload /System/Library/Extensions/AppleHDA.kext 
sudo kextload /System/Library/Extensions/AppleHDA.kext
  • 2
    Awesome, worked for me! – Vojtech Vrbka Dec 2 '14 at 9:30
  • 1
    Worked for me too! – hfossli Jan 23 '15 at 20:34
  • 13
    After killing coreaudio I also did: sudo kextunload /System/Library/Extensions/AppleHDA.kext sudo kextload /System/Library/Extensions/AppleHDA.kext – Neil Mar 3 '15 at 22:01
  • 3
    I had to restart Spotify after applying this fix but it worked. Thanks! – Christian Juth May 10 '15 at 3:06
  • 4
    Funny how this still happens one year later. Running Yosemite here. Thanks for the help. – Paul-Sebastian Manole Jun 17 '15 at 8:47
37

Simple Hack: Plug in a pair of headphones, then unplug them. This will allow you to control the volume again.

  • This worked fine for me – Vitor M May 6 '15 at 15:25
  • 1
    This is not working for me; interstingly, i jsut started getting this behavior when plugging in the same headphones i've been using for a year, and sometimes it now stays in this mode after unplugging the headphones. – Vynce Oct 20 '15 at 7:19
  • 1
    I tried the sudo killall coreaudiod approach, and that didnt work - this did! – Brad Parks Apr 27 '18 at 12:12
22

This icon appears when the external device or application has taken over and is to be used to adjust volume.

That also means the internal speakers are disabled.

To verify, go to system preferences sound, and look in the output tab which device is to be used to adjust volume.

See following example

If I select the Sharp TV I will get the icon like you have if I try to adjust volume on may mac, so i have to use the TV volume adjustment.

However if i select Internal speakers the volume adjustments works on my mac.

volume adjustment device

7

I think I found a quicker and easier fix. At least it works for me.

When the volume keys don't respond (happens pretty often and I haven't figured out why) I simply put the computer in sleep mode then re-awaken it. Takes a few seconds but it works every time.

5

If all else fails, open a terminal window and type the following to adjust it your volume:

sudo osascript -e "set Volume 5"

You can change to "5" to a higher or lower number to make the volume go up and down

4

This happened to me too I just shutdown the mac and turned it on again, after this it was back to normal.

3

I just plugged an audio device back into my macbook air, worked. didn't need to put to sleep or do some code or restart.

  • Interesting the most simple yet effective advice. This immediately worked for me too. – JGallardo Nov 11 '15 at 21:56
1

I tried all the other answers (enabling the internal speakers, killing coreaudiod, putting the computer to sleep), but the only thing that worked for me was a reboot.

I also read somewhere that rebooting into safe mode might fix it, but thankfully I didn't need to do that.

1

The easiest way to fix this when it happens to me (usually when I unplug my headphones) is:

  • Go to System Preferences -> Sound
  • Adjust the slider bar at the bottom where it says "Output volume".

Even a small adjustment to the aforementioned slider bar re-enables the keyboard volume controls for me.

The question I actually want answered is why the problem happens in the first place. Please let me know if anyone finds out.

  • Regarding why it happens in the first place: I came across this video, which seems to indicate that the headphone jack still thinks the headphones are plugged in. youtube.com/watch?v=lILTI3jpnEE Seems like a hardware problem. – Nate Aug 21 '17 at 20:44
0

I just rebooted and it worked for me! Been having this trouble since I did the last round of updates.

0

I had this problem twice within this week, first time it happened.

I checked the settings but did not have any other audio device connected. Tried putting my computer to sleep and waking it again, tried quitting the sound applications and started it again, all didn't work.

What worked was I adjusted the volume in the settings by dragging the volume bar manually and I was able to use my volume buttons again.

Kinda annoying.

You must log in to answer this question.

protected by Community Feb 21 '15 at 0:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .