7

My partner has a hand-me-down iPhone 4s, and a few months ago, the home button started playing up and not pressing. She started using the on-screen home button instead, which has solved the problem of not being able to press the home button.

Now though, the home button is more responsive, even too responsive. We started noticing that she had called random people (totally random, not most recent or near the beginning of the alphabet or anything) while the phone was in her bag, and occasionally while locking the phone, it would issue a camera shutter button as if it had taken a screenshot. Now it is frequently activating voice control, even if it is just sitting on the table.

It's pretty clear that the problem is that the home button is sticking down sometimes, and is often opening voice control, and as a result, dialling random people (apparently the voice dial software is oversensitive and thinks anything is a name, rather than saying 'sorry, cannot find "hrrghgsh" in your contacts'.

Other people who have had this issue have said that you can turn off voice dial (but not voice control) via settings > general > passcode lock, however my partner's phone has no such setting for voice dial in passcode lock, or anywhere else as far as I can tell.

Can anyone tell me where voice dial has moved, or if voice control itself can be entirely disabled (as one would expect to be possible) or alternatively, if the home button itself can be entirely disabled?

  • It appears the kind folks at Apple have made this impossible. My partner decided to just get a new phone as this problem is rather fatal to this phone's continued usefulness. – Jangari Apr 12 '14 at 1:09
3

There is a way to make home button not to work wheb the home is lock. First activate Siri setting >General> Siri > ON Then If iphone 5s (may be it work in iphone 4a) setting >Id&passcode> there is an option where it tell to siri off when phone is lock. make sure you put it off. Thats it home button wont work when phone is lock. Preventing voice control to make stupid random call

  • You should also set immediately lock in Settings -> Passcode – k06a Apr 21 '14 at 10:06
  • However, this requires Siri to be switched on. There is no way of having both Voice Control and SIri switched off, at the same time. – Greenonline Sep 24 '16 at 17:41
1

I am experiencing the exact same situation on an iPhone 5. My home button is also sticking and the hyper-sensitive voice control is attempting to call people even when I am silent. As far as I can tell after painstakingly going through every single setting available, and researching on forums etc. The option of disabling voice dialling has been taken out of iOS7.1. I have not been able to find any mention of it anywhere.

EDIT: After reading through some information in Siri, I have restricted the use of Siri altogether (which may be a possible fix) You can do this at: Settings > General > Restrictions (Enter a passcode lock) and deselect the bar next to Siri as allowed content.

  • Is Siri the same thing as voice control? I would assume so, but isn't Siri restricted to iPhone 5? My girlfriend's phone is a 4s and AFAIR, there is no setting for Siri. I'll have her check though; thanks for the tip. – Jangari Mar 20 '14 at 19:19
  • Siri is on the 4s – dwightk Apr 12 '14 at 18:42
1

This setting seems to have been removed. Prior to 7.1 it was in:

Settings > General > Passcode > Voice Dial > OFF

Since 7.1 things have moved around a bit in settings, and the equivalent area would now be:

Settings > Passcode

...only the option is absent. Hopefully it will be returned, as my sticky home buttoned iPhone 4 is also occasionally dialling nonsense for me.

So, to summarise, there seems to be no way to turn it off for iOS 7.1 on a non jailbroken iPhone.

0

I am from Brazil and I am facing the same issue with my 4S 7.1; The Voice Control activation occurs suddenly (locked or not; and also while I am using the phone... it closes my current application as a pressed Home Button). And sometimes random calls are been made.

Then, I tried to disable the Voice Dial but as already said, it does not appear... To able SIRI... Ok, the phone stop calling people, but other similar things occur with Siri.

So, What Did I see? After I turned ON the Siri, I came back to GENERAL->PASSCODE... And NOW, I can see the option to disable VOICE DIAL (SIRI is still ON). After, I disabled SIRI and by now, My phone is working properly! OK, Sometimes, my current application is wrongly closed, but no more Voice Control or SIRI appears... (by now) :)

That's it! Sorry in case of not so clear English Language...

0

Turning Voiceover Off

  1. Double-tap the Settings icon on your homepage.
  2. Use three fingers to scroll down to the General menu, and double-click on it. Click for image.
  3. Use three fingers to scroll down to the Accessibility menu, and double-click on it. Click for image.
  4. Double-tap on the VoiceOver menu item. Click for image.
  5. Turn VoiceOver off At this point your phone should be back to normal.
  • 2
    This is for disabling VoiceOver, not Voice Control. – grg Aug 8 '14 at 17:28
-1

Setting -> general -> accessibility -> VoiceOver -> OFF

It was really annoying I just find it useful.

  • 1
    This doesn't disable voice control. – grg May 6 '14 at 9:54
-2

Try this if you are looking to turn off the voice control.

Solution 1

  • Go to Settings/General/Accessibility/ Voice over/ Select "No"

Solution 2

  • Press 3 times the Home button.
  • You should get the "Disable Voice Over" option.
  • Hit the button twice to disable it.

http://en.kioskea.net/faq/9566-iphone-disable-the-voice-over-feature

  • 1
    Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg May 1 '14 at 17:03
  • With 7.1.1 attempting this doesn't work. When you restrict Siri from being accessed it turns it off and reverts to plain Voice Control (which will function even when the phone is pass code locked.) – jrg May 19 '14 at 20:52
  • 2
    This is for disabling VoiceOver, not Voice Control. – grg Aug 8 '14 at 17:28
-3

Settings>General>Restrictions. Turn OFF Siri

If you forgot Restrictions code , pls watch it and solve problem .

http://www.youtube.com/watch?v=xalgQNLKH-w

You must log in to answer this question.

protected by Community Aug 8 '14 at 22:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .