19

Mavericks keeps launching recent applications at startup although I always keep the checkbox that should control this feature unchecked. This is really annoying, because (a) startup takes much more time, (b) I want to decide which applications are to be started and which are not, and (c) there are some applications that would crash (Apple's own Logic, for instance).

If I knew where OS X kept information about recent applications, I could write a script that deletes that at login. Has anyone figured out where these things are put?

EDIT: I'm also interested in the location where Mavericks puts the screenshot from last session. As you might have noticed, the screenshot is always shown first when logging in, then the screen is refreshed with the actual window contents.

4
  • the checkbox in login-items will only hide the application (it won't prevent it from starting). To remove/prevent a specific login item in User Accounts from starting mark the item and press "-"
    – Chrisii
    Mar 19, 2014 at 12:40
  • 1
    I'm not talking about login items. I'm talking of Maverick's special feature that relaunches recent applications automatically when logging in.
    – digory doo
    Mar 20, 2014 at 14:06
  • you should make your new additional question a separate question @digorydoo
    – dwightk
    Mar 20, 2014 at 14:36
  • I figure the info about running apps and the screenshot are stored in the same location, but I might be wrong.
    – digory doo
    Mar 21, 2014 at 16:44

3 Answers 3

18

There are three official places I know of that unwanted items on startup are controlled:

1) Login preferences: if you want to delete an item, make sure you highlight it and then click "-" instead of just unchecking it. If it is unchecked, it will still start, it will just have a hidden windows.

login preferences

2) "General" - make sure "Close windows when quitting an application" is checked. This shouldn't control which applications actually open, but I've seen some people confuse unwanted windows with unwanted apps.

general

3) The "Reopen programs when logging back in" dialog on logout – this should be unchecked.

In addition, there are some unofficial tricks you can try:

Disable ApplePersistence:

defaults write -g ApplePersistence -bool no

Note that this will also disable Versions (autosave)

Set "System preference>General>Recent items" to NONE (default is 10)

ref:

The first three tips have worked for me; the last two are from https://discussions.apple.com/thread/5538748?start=0&tstart=0

5
  • 1
    In (1), the checkbox hides the application's windows on startup. It is not to do with menu bar item.
    – Gilby
    Mar 18, 2014 at 23:01
  • I wasn't talking about (1). As for (2) and (3), I unchecked these checkboxes, but from time to time Mavericks seems to ignore my choice and relaunch the applications all the same. I'll try disabling ApplePersistance, this might be the solution, but can't try it at the mo'.
    – digory doo
    Mar 20, 2014 at 14:10
  • None of these worked, but the "Open at login" option available through the Dock icon was the one to uncheck.
    – oligofren
    May 4, 2015 at 19:40
  • None of these worked for me on macOS 10.12, not even @oligofren's option.
    – Flimm
    Sep 12, 2017 at 9:19
  • I keep seeing these same recommendations on various forums, but they are not working for me and never have on different versions of Mac OS X. I'm now running macOS 10.13.3. and STILL have to manually close all my applications or they will always reopen upon restart. Does anyone have a solution?
    – user24601
    Mar 10, 2018 at 14:01
8

Your question isn't (or at least wasn't) very specific. So there are multiple answers you may find helpful when trying to control annoying apps that open at log in:

  1. Keyboard shortcut to disable items from starting up while logging in
  2. Buttons to click to "officially" remove startup items
  3. Places to look to actually remove startup items


1. Keyboard shortcut to disable items from starting up while logging in

Temporarily disable items from starting up at login by holding the shift key. When to hold the shift key is conditional:

If your computer goes to the login screen before logging in, hold shift while you log in and release when the dock loads.

If your computer skips the login screen, hold shift when the progress bar appears after a restart and release again when the desktop/dock loads.

Found some proof that this is a feature: Apple support knowledge base article.


2. Buttons to click to "officially" remove startup items

Go to: "System Preferences > Users & Groups > Login Items". Remove unwanted items.

Also, as you have done, make sure to uncheck the option that shows when logging out to re-open apps.


3. Places to look to actually remove startup items

There are some other places that are hidden and you can't fix with a checkbox or button. Check "/Library/LaunchDaemons" and "/Library/LaunchAgents".


If none of that helps, you might have a tricky case, and you can try using the Google to find other secrets like this article at Macworld.

4
  • Nice find. I couldn't dig that up a while back...
    – bmike
    Mar 14, 2014 at 23:28
  • Nice, I gave you an extra up vote.
    – Joe Hansen
    Mar 14, 2014 at 23:29
  • I wasn't asking about temporarily disabling it, I want to permanently get rid of the feature.
    – digory doo
    Mar 20, 2014 at 14:11
  • I've updated my answer and hope you find it more useful.
    – Joe Hansen
    Apr 28, 2014 at 22:21
5

You need to right click/tap that particular app to reveal a pop-up menu> under Options > un click> Open at Login

and that should solve it...restart your computer to see if it does it again. This should solve it as I have the same problem with Chrome.

See the image attached below:

enter image description here

1
  • That was it! Thanks a million. But how did it become checked in the first place?
    – oligofren
    May 4, 2015 at 19:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .