4

I have a problem with copy and paste of characters like "ü". When I copy and paste the name "Gereon Müller" from this book http://langsci-press.org/catalog/book/18 (choose the download tab) I get the ü decomposed into two characters on a Mac. This does not happen under Windows and Linux (xpdf, acroread, sumatra), but it does happen on a mac with acroread and with skim. Any ideas?

Edit: These are the two characters: ü In the text you can see an ü, but it is actually an u with two dots that are shifted over the u. Look at this: ẗ (as you can see, I composed a t with these two dots). This is not a problem for reading the ü, but if I want to continue to work with this ü I get problems, since LaTeX does not like these characters at all. In emacs I can edit these two characters seperately.

Edit II:

I played with different applications and they behave differently: Word gets one copy and paste right, while emacs gets both wrong.

Word:

Word

Emacs:

emacs

Edit III

And this is text edit:

enter image description here

  • what 2 characters ? and explain the paste to where ? what is "skim" ? – Ruskes Mar 14 '14 at 11:43
  • what about Apple's standard pdf-reader "Preview" ? – Kevin Grabher Mar 14 '14 at 14:59
  • The problem is also present with preview. – Stefan Müller Mar 14 '14 at 16:23
  • Wow, I have never seen TextEdit do that, and I can't duplicate it (copy/pasting Stefan Müller from page x of that book with Preview and using Minion Pro). Try a safe boot (to fix possibly corrupt caches) and see if it helps. support.apple.com/kb/PH14204 – Tom Gewecke Mar 17 '14 at 23:42
  • I tried this. No change. Can I remove the caches via command line? – Stefan Müller Mar 18 '14 at 9:27
1

If having such characters in decomposed form (represented by two codepoints, base character plus combining accent mark) is a problem for further processing you need to do, then you can use an app like Unicode Checker to convert the text to Unicode Normalization Form C. That will change them into the composed, single-codepoint form.

http://earthlingsoft.net/UnicodeChecker/

0

I reproduced your steps:

The Book is in English and in Adobe pdf format.

I downloaded the preview and found some examples with "Umlauts".

Copy and paste them in to my Notes.

Güldemann Joël König

As you can see it works perfectly well.

Suggest you check and update your Adobe reader to XI version.

  • All software is uptodate. – Stefan Müller Mar 14 '14 at 16:29
  • so tell us where do you copy it to ? maybe that is the problem since it works on my MBA 10.9.2 with Adobe Reader XI.-German keyboard ! – Ruskes Mar 14 '14 at 16:40
  • I copy/pasted a ü from the text into TextWrangler and did a hex dump and verified that it is being represented as two characters, u plus combining umlaut. This should normally display OK, unless there is a bug in the font or the app. – Tom Gewecke Mar 14 '14 at 18:10
  • copy it into notes and see if it works there – Ruskes Mar 14 '14 at 18:12
  • I copy and pasted it to word and to textedit and the ü comes out as two characters. Strangely enough I can copy another example to word without problems but emacs hates it. I post screenshots in my question. I disabled all fonts that I installed in my fontbook. – Stefan Müller Mar 17 '14 at 18:23
0

"ü" is almost always represented as a single character in text encoding schemes, but I have been informed that it can also be represented as two characters. In Unicode, for example, "ü" is represented as a single "precomposed" character as 00FC. However, it exists as a less-commonly-used two-character grouping as 0075 0308.

You are encountering a strange bug or incompatibility. I suggest that it may be that the word processor program into which you are pasting the text has been set, for that document, to use a type of (old and obsolete) character encoding that does not properly recognize the "ü" character. Either that, or there is some strange problem with the way that this particular PDF you are working with has been character-encoded.

By inspecting the PDF you linked to, I see the following:

Application: LaTeX with hyperref package
PDF Producer: xdvipdfmx (0.7.9)
PDF Version: 1.5 (Acrobat 6.x)

I do not understand the implications of this, having no experience with LaTeX, but perhaps this could provide a clue.

The next step in troubleshooting the problem is to find several different PDFs from different sources and different websites that also have German in them, and see if you have the same result when you copy text out of them and paste them into whatever word processor you are using. If you cannot reproduce the problem, then it's a problem with that particular PDF.

Then you should try pasting German text with umlauts from the various different PDFs into new blank documents in different word processor programs (Apple TextEdit, Bean, Apple Pages, Microsoft Word, OpenOffice, whatever you have on hand) and see what results from that. The problem might be a quirk in one particular word processing program and its preference settings.

I assure you that it is highly unlikely that you are having any kind of problem with the Mac OS X operating system itself. I routinely work with writing text and making PDFs in several languages with diacriticals, including German, Spanish, Italian, and French, and I have never encountered a problem like that which you are reporting.

  • OK, thanks, I will incorporate your correction in my answer. – user9290 Mar 14 '14 at 19:19
-2

"Type German characters - online German keyboard", type your letter and when finished copy it to the document you need it on (in my case, I copy it to my email, no problem). That online keyboard comes in a lot of languages. Look it up, it's good, it's under German.typeit.org

  • Where do you 0 down vote "Type German characters - online German keyboard"? – Mark Feb 15 '18 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .