2

When I am running my localsite/~user.name/ on OS X 10.7.5 it is loading the the correct page but in the log /var/log/apache2/error_log it's recording this message.

[Fri Mar 14 00:17:07 2014] [error] [client ::1] client denied by server configuration: /usr/~

Here is my httpd-vhost configuration for localhost

<VirtualHost *:80>
  ServerName localhost
  DocumentRoot "~/Sites"
  <Directory  "~/Sites">
    Options Indexes Multiviews
    AllowOverride All
    Order allow,deny
    Allow from all
  </Directory> 
</VirtualHost>

A check of apachectl -t shows no unexpected errors since I'm using localhost and don't need fully qualified DNS:

httpd: Could not reliably determine the server's fully qualified domain name, using MacBookPro.local for ServerName
Syntax OK

I am serving plain text files with basic html in them. What could be the reason for this?

  • What sort of web page is being served? Have you enabled cgi-bin or other changes to the apache config file? (also anything odd from apachectl -t) – bmike Mar 13 '14 at 19:31
  • The page served is a plain html/text file. And the output from apachectl -t is following :- httpd: Could not reliably determine the server's fully qualified domain name, using phillip-MacBookPro-344.local for ServerName Syntax OK – John Doe Mar 13 '14 at 19:34
  • You're most welcome. Let's see if people have ideas... I'm wondering if it's just a harmless error that some potential module might need to access /usr and the permissions are set to prevent that unless you enable that module (which presumably would change permissions or relax the check causing the "error") – bmike Mar 13 '14 at 19:41
  • How can I find that module? Sorry I am pretty novice in these things. – John Doe Mar 13 '14 at 19:49
0

access to the directory on the hard disk was denied by an Apache... that can be an explicit deny directive, or if the dir is outside of document root.

I suspect you don't have (and don't want!) /usr as part of your documentroot.

  • My documentroot is the Sites folder in my home directory. – John Doe Mar 13 '14 at 19:35
  • As is evident from the above config the DocumentRoot is the Sites folder in my home directory. How is /usr coming into picture here ? – John Doe Mar 13 '14 at 19:45
  • the request log shows /usr/~. I think it is not interpreting ~ correctly as your home directory. – marathon Mar 13 '14 at 19:53
  • Sure I meant rather my documentroot does n't have that directory in the path. – John Doe Mar 13 '14 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .