7

My iMac 27" screen went black on start up after logo, but I could still see my mouse pointer. I've restarted my computer and it is still not helping at all.

I'm running Mavericks 10.9.2 with an i5 processor and 4GB RAM.

Couple things that I've done:

  • I did a PRAM reset with , , P & R at start up and still no luck.
  • Launched Disk Utilities by holding command & R keys at start up, ran disk diagnostics and got a good message. I also click all repair related buttons and still green message appeared OK.
  • I booted up into Safe mode and still no luck.
  • I ran Apple Hardware Testing and the result is good.
  • I've reinstalled OS X Mavericks and still the same problem.

I'm wondering what would be the possible culprit with this kind of issue?

  • There is no such thing as 10.9.x so please be specific as to which version you actually have – Andrew U. Mar 13 '14 at 9:22
  • Could you also be a bit more specific as to the time and previous things that appear on the screen before it goes black? Is there a spinning gear? Does the screen flash? Grey screen and mouse and then a black background with mouse? – Andrew U. Mar 13 '14 at 9:26
  • There was mention of this issue on an Apple techs sub reddit on Reddit a few days ago. The suspected fault was with the /Library/Preferences/com.apple.loginwindow.plist preference file. Those of us who had already come across the issue had fixed it by erasing/installing the affected Macs so we couldn't test it. I would recommend booting to single user mode (command+S while powering on), entering the two commands it recommends once it loads, then running (without the quotes) "rm /Library/Preferences/com.apple.loginwindow.plist", then rebooting by typing reboot. Plz let us know if that works. – Mr Rabbit Mar 13 '14 at 11:27
  • @James Wise please only use Single User mode if you are comfortable with Terminal/unix and have a backup. If you mistype a command or enter a wrong file you could lose files or damage your system in other ways – Andrew U. Mar 13 '14 at 11:33
  • @MrRabbit I tested that and it's still the same. – James Wise Mar 14 '14 at 2:01
8

I've ran into this issue a couple of times now, this is what has resolved the issue each time. Step 5 sometimes returns a "file not found" error and step 6 doesn't always seem to be necessary but has been in some cases. Regardless, having in their doesn't seem to have an negative effects.


  1. Boot to single user mode (hold S while powering on the Mac)
  2. Type and hit return: /sbin/fsck -fy
  3. Type and hit return: /sbin/mount -uw /
  4. Type and hit return: rm /Library/Preferences/com.apple.loginwindow.plist
  5. Type and hit return: rm /Library/Preferences/loginwindow.plist
  6. Type and hit return: rm /private/var/db/.AppleUpgrade
  7. Type and hit return: reboot

Assuming all instructions were followed the Mac should reboot and reach the login screen with no trouble. The instructions above should be followed VERY carefully, with attention paid to spelling and spacing, as there aren't many safeguards in single user mode to prevent you from deleting otherwise necessary files.

If you have access to another Mac and a Firewire/Thunderbolt cable you could boot this Mac in Target Disk Mode ( T while powering on) and connect it to the spare Mac to remove the files from the GUI. You would need to open the iMac's system volume (default is Macintosh HD) and remove or rename the two files mentioned above in Library/Preferences.

Hopefully that helps!

  • I tested this steps and it is still not working. The /Library/Preferences/loginwindow.plist file is not existed and only com.apple.loginwindow.plist. – James Wise Mar 14 '14 at 1:54
  • @JamesWise - I'm sure you've resolved this by now, but on the off chance you haven't you should attempt the second part of my answer that I just added. – Mr Rabbit May 23 '14 at 16:31
  • 1
    I'm facing the same issue on this now and I've followed your steps which is really working! It seems like Apple upgrade is having issue.... Thanks Mr. Rabbit! – James Wise May 27 '14 at 1:38
  • @JamesWise - I just helped another one of my employees with this over the weekend. Seems to be occurring again. Glad it worked for you! – Mr Rabbit May 27 '14 at 14:17
  • 1
    This has just saved me from a very nervous morning. I'd give you a bounty to say thanks but I don't have enough rep to spare, so a +1 will have to do. – Mark Henderson Aug 27 '14 at 22:53
0

I'm having this same problem and yet, it is different. I note all over the Web a variety of like, but different versions of the problem. Solutions that work for one, do not work for all, even when the descriptions ARE identical.

My mid 2011 27" iMac 10.13.3 Radeon 6970 blanks out (flashlight trick does not work) while second monitor remains active. I can be in mirror mode or not. It may or may not flicker intermittently before blacking, or after recovery. Usually, the only way I can recover is to use the Sleep command from the second monitor (forces me to use mirror or insure the second is setup to have the menu bar).

Using the sleep function usually blanks out the second screen briefly and then both return, as if Finder Relaunch. Sometimes, it puts the system to sleep and I can return normally. It can require anywhere from one to twenty or more repeats of this operation one after the other for a day-long fix, or rear its head again later, several times a day.

Not one of any of the other many solutions offered elsewhere will work. I will add that I often use my second for TV and if the iMac blacks, I have to switch back to second display use in order to 'sleep' it, again. Very hard to watch NASCAR while computing. Hard enough to do dual screen computing.

-2

So as I understand you have reinstalled Mavericks. As you have been able to use the installer (Recovery HD) the hardware should be fine. Please note though that usually when you reinstall Mac OS X it will keep all your settings and programs. This might mean that the thing causing your troubles is also kept intact.

To resolve this, I would suggest the following:

  1. Boot from recovery HD
  2. Make a backup using disk utility to external drive (if neccesary)
  3. Erase Macintosh HD
  4. Install Mavericks

This should resolve your problems, provided that there is really no hardware failure. If this doesn't help, you can rule out software failure and your best bet is to go to an Apple Store.

  • If it boots to the recovery HD, as I suspect it will from similar experience, then that alone rules out hardware since it's a similar build of the OS but a separate system. I do agree that an erase and install will fix it though. – Mr Rabbit Mar 13 '14 at 11:30
  • 1
    And then what? Should he restore from a Time Machine backup or just drag and drop files? Your answer needs a bit more meat to it so that he doesn't just have a system that might boot but he doesn't have is files – Andrew U. Mar 13 '14 at 11:34
  • @ Mr Rabbit: Not entirely, not all drivers are loaded. I once had an issue with a MBP which had a defective GPU but would work when graphics drivers were removed. As soon as there was any acceleration it would bork. – Steven H Mar 13 '14 at 11:44
  • @ Andrew: You're right, after that he should recover his files from the backup – Steven H Mar 13 '14 at 11:45
  • I'm thinking about this method as my last resort. I just need another external USB hard drive to backup the files. Question - how to mount my external USB hard drive as NTFS with read write permission? When I hook it up, the system mount it as read-only. – James Wise Mar 14 '14 at 1:59

You must log in to answer this question.

protected by Community May 25 '14 at 1:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .