How do I disable automatic iTunes launch when iPhone is plugged in via USB (for charging)? In fact, I would like to disable automatic launch of anything when an iPhone is plugged in (including photo sync).

marked as duplicate by drfrogsplat, M K, grg, Rob, nohillside Jun 13 '14 at 11:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 86 down vote accepted
  • iTunes

    Open iTunes, select your device, go to the Summary tab and unselect either Open iTunes when this iPhone is connected, or Automatically sync when this iPhone is connected depending on your version of iTunes.

    Also, you might wish to disable iTunes Helper. Go to System Preferences → Users & Groups → Login Items and delete iTunes Helper from the list.

  • iPhoto

    Open iPhoto, open Preferences (iPhoto → Preferences or ⌘,). Select General tab and set Connecting camera opens to No application.

  • Photos (new version of iPhoto)

    Let Photos open when you connect your device, select the "Import" tab and untick the box for "Open Photos for this device"

  • 21
    Note that some people have reported the "Open iTunes when this iPhone is connected" option does not appear in the list. Not sure exactly what the conditions are, but the only relevant option is whether automatic sync is enabled (disabling it prevents iTunes from opening, but also prevents auto-sync when you manually open iTunes). That said, disabling the iTunes helper in login items does fix the problem. – drfrogsplat Jun 13 '14 at 1:55
  • @drfrogsplat I too encountered this on the Windows version of iTunes, so I guess that those people who reported it were also using Windows. – Iulian Onofrei Jan 7 '15 at 19:55
  • I don't have an updated iTunes because I don't use it, so the updated iPhone triggers the launch, but I cannot access iPhone Summary tab. I just kill -9 the process related to iTunes Helper (because even with login options item disabled it seems to run). – denmojo Sep 29 '15 at 0:49
  • 6
    Since iPhotos became Photos the option is now located in a different place. In order to stop Photos from opening on connection, let Photos open when you connect your device, select the Import tab and untick the box for Open Photos for this device – bskool Oct 20 '15 at 10:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.