My iPhone 3G is showing

No SIM Card installed
Insert a valid SIM With no PIN lock to activate iPhone

It is in Emergency mode so please give me a solution if there is..?

It happened when I am tried to update the from iOS 4.1 to 4.2.

  • For the sake of sanity - let's assume this question is about a normal "locked" phone that expects a specific carrier's SIM to be installed and the OP is using a SIM from that carrier. Let's also assume it doesn't show in iTunes and can't have apps installed and is completely stuck at the emergency screen. – bmike Apr 19 '11 at 15:36
  • Keep in mind this could be unrelated to the update and just a hardware failure, which still can be as simple as pushing the SIM Recipient hard enough to the bottom or a broken SIM Reader really complicated to replace. Both happened to me in different iPhones. – cregox Apr 20 '11 at 14:40

This is actually a pretty complicated problem with not enough detail to know which one of many things is causing the failure so I'll go over some basics:

  1. Your phone needs to be activated through iTunes after a restore - so something in that restore process didn't work.
  2. The sim and phone have three components - any of which can fail.
  3. The activation process is complicated and has a lot of checks to be sure the image you are installing is not modified so that the phone will work as designed. This activation needs to connect to the internet so even when everything under your control is correct, it still fails from time to time. Problems on your computer with iTunes or the system itself can cause this to happen on an otherwise working phone.

I'm also going to assume the phone is locked to AT&T to keep things simple. If the phone is unlocked legitimately through the carrier and officially recognized by iTunes' activation process this is much more complicated. If it's otherwise modified, the complication is really much more involved so I'll leave those out of the discussion.

Looking at #1 above - the best advice is to reseat the SIM card and then try again to make sure it wasn't a timing or contact alignment issue. Considering #3 above - it's simplest to take your device to a totally different computer and try the restore there - you can always take it back to your computer to put the backup on it once it's working.

Let's look at #2 in more depth - sim and phone. A bad sim will cause this - you'll need to get another SIM to test this and replace the SIM with one active from your carrier if it's the cause.

Have you tried another SIM from your carrier - it doesn't have to be attached to an active contract or active line - it just has to be working. Try to rule out that the sim itself is bad or has failed. A good SIM will get you to "waiting for activation" and a full restore so you can copy apps to the phone and otherwise use it on WiFi. Putting your SIM in another phone can help know that your SIM is not bad, but it has to work in your phone, so you may need to get another SIM even if yours works in another device.

Once you rule out the SIM - you'll need to rule out software. Do another restore of the phone following this knowledge base article. If that doesn't work, force the device into restore mode to get the software loaded properly. Be sure there's not a failure in the restore process or you'll be wasting time on SIM olympics or getting your phone swapped.

That's the third part of #2 - if your phone has a failure (dust or dirt, contact problems, moisture or corrosion on the inside that is causing the circuitry to break, or just a random electrical failure) you will need to get it in for service. There a technician will have the tools (otoscope, test rig, test SIM, good software to restore your device) and the training to know what worn contacts look like to know if it's a cleaning/reseat issue or a hardware repair is needed.


Your iOS update from 4.1 to 4.2 has relocked the device to its previous network. You need to unlock your device using a permanent unlocking method to avoid such hassle on your every future updates. I would suggest you to get the remote unlocking service from Onlinegsmunlock.com this method of unlocking is safe, simple, affordable, quick and permanent. /it doesn't require a jailbreak too. Good luck.

  • Your carrier has to do this for Free after 1 year. Since it's a 3GS I would recommend the free method first. – Rob May 15 '14 at 6:04

try to restore it using redsnow and try also to watch this video http://www.youtube.com/watch?v=T9BMXflZKiM

  • How does this help? can you describe what the video does and not just provide a link. Note that RedSnow is a jailbreaking program and so not supported by Apple. – mmmmmm Jun 5 '13 at 14:39
  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – Daniel Jun 5 '13 at 17:09

You must log in to answer this question.