2

I have an absurd issue which pretty much nothing seems to be able to fix -

I have a 2011 Macbook Pro running Mavericks. When I try logging into my main account with the correct password, the wheel starts spinning, but then the screen acquires a blue tint, flashes, and then returns back to the login screen, asking me to enter my password again.

I created another Admin account which seems to login perfectly. In fact, I am unable to login even through Safe Mode...

I tried the following things -

  1. Removing the password - this resulted in a login loop
  2. Resetting PRAM
  3. Reinstalling Mavericks
  4. Rebuilding the user account
  5. Removing the LaunchServices files
  6. Removing the cache files

I tried literally everything but nothing seems to work!!!

This problem happened right after I was trying to connect my Macbook to an external monitor.. It wouldn't show the screen so I kept inserting and removing the cable..

Please feel free to be as technical as you want. I'm a CS major :)

  • When you were in the other admin account, did you check your original user's login items? They can be found under System Preferences > Users & Groups > USERNAME > Login Items. Try removing all of them and see if that solves the problem. – Arc676 Mar 11 '14 at 2:43
2

There is one troubleshooting step that OS X shares with the classic Mac OS, removing preference files. But on OS X there are TWO folders:

/Library/Preferences and ~/Library/Preferences

--The latter being in your user/home folder--

Since the issue doesn't exist under another logon it is specific to that user folder. SO there is something specific to that user that is causing the problem. This takes the /Library/Preferences folder out of consideration for troubleshooting preferences. The first thing I would do is use a utility like Onyx to verify and clean the system. This includes verifying preferences files. After that rename the ~/Library/Preferences folder to something like

~/Library/Preferences-old

You'll probably have to do that in Terminal and use sudo as those files are owned by another user on the system. then create a new ~/Library/Preferences folder and reboot.

If you can now log into that account it is a simple (HAH!) matter of putting preferences files in the new Preferences folder and rebooting till you find which one it is.

No guarantee, though, that it is a preference file, it could be a startup item. So do the same thing with the ~/Library/LaunchAgents folder.

The other thing to consider is that it might be easier to just create a new user folder. Copy the things you need out of the old user folder and delete the old user. That could save you a lot of troubleshooting time. It would be my preferred way of doing it (after running Onyx) as I care less about what happened than just finding a fix that gets me up and running more quickly.

  • You are most welcome! Something you learn in the IT biz, sometimes the solutions for major problems are tiny things. The skill comes in knowing which haystack to look in. – Steve Chambers Mar 12 '14 at 13:27
  • I had the same problem, I had to get rid of all the Preferences and then put them back in chunks until it broke, then split that chunk and tried again, then again till I worked out which ones were the problem. – Pete Aug 4 '14 at 16:43
  • Anybody remember extension managers like Conflict Catcher? Jeez this is sounding more and more familiar... – Steve Chambers Aug 5 '14 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .