8

I have downloaded music directly from iTunes onto my iPhone from the app. The problem is some of the songs I don't want on my iPhone and I just do not have the space for it, and I would like to add different music to my iPhone. The problem is I have "show all music" unchecked, I also have "automatically download music" unchecked, as well as pretty much every answer that has been given online to resolve this problem. I don't use iCloud or iTunes match.

I even closed the music by going to general > usage > music and deleting all of the data. That still didn't work. I even factory reset my phone, and once I sync my phone the purchased music will completely sync back onto my phone. I know it is only the purchased music, but seeing as I only have a 16GB iPhone, I absolutely NEED more space, and it is killing me that the only way to get rid of it is to manually delete each of the 500 individual songs by swiping left on the iPhone.

If anyone can help me I would really really appreciate it. I've spent countless hours being frustrated by my phone trying to get this music off in order to have space to add new music.

1

Any songs I had in a playlist called "purchased" kept reappearing (Even after I deleted all music from the usage setting). Once I deleted that playlist they did not.

0

It sounds like your problem is not the settings on your phone but rather the settings on your computer.

Some options for what you might do:

  • change settings in iTunes so that you do not automatically sync
  • change settings so that you only sync songs that are selected (check marked) in your iTunes library
  • delete songs from your iTunes library that you don't want on your phone
  • don't ever plug your device into the computer and manage your songs solely with the phone

Here are two pictures you might find helpful within iTunes:

In iTunes preferences, see Devices Preferences.

itunes device preferences

Also, after plugging in your device, select it from the iTunes menu or in the top right area of iTunes and scroll down to see some other options.

itunes options on device screen

0

I've just been through this and this is what worked for me:

First make sure your phone is unplugged from iTunes on your computer.

Go to the iTunes Store on your computer and hide all your purchased music. (Probably you just need to hide the music you don't want but I hid everything because you can still select the song manually to sync to your phone).

Then on your phone:

  1. Go to Settings > General > Usage > Music
    • Then hit "Edit" and delete all of your music.
  2. Go to Settings > Music and turn OFF "Show all Music"
  3. Open Music and it should say "No Content"

Once the phone is clear you can Sync your phone to iTunes on your computer.

  • Note: Under "Summary" on the iPhone tab in iTunes make sure at least "Sync only checked songs" is checked. Under the "Music" tab make sure that "Selected Playlists, artists, albums, and genres" is checked.

That should make sure that only music you want makes it to your phone.

Hope this helps.

  • How do you " hide all your purchased music" – Mark Sep 2 '15 at 9:49
0

I had the same problem! I did this : http://support.apple.com/kb/ht4919

Before I did that, I did delete all my music from the phone. Settings>General>Usage>Music and under music I hit EDIT and deleted with the minus button.

It worked. After hours of frustration over horrible purchases, I finally was able to remove all the songs I didn't want on my iphone.

  • 2
    Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg May 25 '14 at 21:05
0

While the music does appear on your iPhone, did does not necessarily mean that it is taking up storage on your iPhone. I also have a 16 GB iPhone and was trying to delete my purchased music.

What I found is that those songs are stored on Apple's server in iCloud and thus are available to you whenever you have an internet connection. As soon as you turn off Wifi and cellular data, however, the songs are no longer playable. This suggests that they are not on your iPhone's hard drive and therefore shouldn't be a problem for storage.

Give this a try for yourself and see if your issue is the same as mine.

So in summary, your problem is not a problem at all, but in fact is kind of a nice feature. Songs free of storage.

-1

It seems odd that it's downloading the purchased music even though you have automatic downloads turned off.

However, try connecting the phone to your computer and configuring the songs manually in iTunes. You can select only certain songs to sync, ask iTunes to "only sync checked song and videos" (this means if their checked in your Library, not in the sync window) and also "manually manage music and videos". Anything not selected, included the wanted purchased songs, will not be synced and should be removed from the device if their not specified to sync also. Have you tried this?

Hope this helps.

-1

had same problem. Go to 'settings' then 'itunes & apps store' then under 'SHOW ALL' switch off 'MUSIC' and 'VIDEOS'

  • with icloud off, then re-sync. fixed problem for me. – steve Mar 15 '14 at 11:31
-1

In the settings on your phone under store, sign out and stay signed out.

You must log in to answer this question.

protected by Ian C. Aug 6 '14 at 23:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .