2

I have a MacBook Air in my office that prompts to pair to a BlueTooth keyboard every 5-10 seconds.

I turned BlueTooth off/on. Made sure it is not discoverable. Restarted. Run updates. Reset PRAM. Reset SMC. Deleted com.apple.bluetooth.plist (~/Library/Preferenes/ and /Library/Preferences/). Removed the offending and from the above plists. With no luck.

I have also taken another computer up next to the MacBook Air running iStumblr as well as the Set Up Bluetooth keyboard and the keyboard cannot be found by either the MacBook Air or the other Mac. But the prompts still persist on the Air.

I have not been able to find any other suggestions re: how to stop the prompts.

Finding the keyboard is going to prove tricky as it is in a large office environment.

Any other suggestions?

EDIT: Console

11/03/14 3:11:28.000 PM kernel[0]: ### ERROR: opCode = 0x0406 (Disconnect) -- send request failed (err=0x0012 (kBluetoothHCIErrorInvalidHCICommandParameters))
11/03/14 3:11:28.000 PM kernel[0]: [0xffffff8016117200][free]()
11/03/14 3:11:31.000 PM kernel[0]: ### ERROR: opCode = 0x0406 (Disconnect) -- send request failed (err=0x0012 (kBluetoothHCIErrorInvalidHCICommandParameters))
11/03/14 3:11:31.000 PM kernel[0]: [0xffffff8013f74700][free]()
11/03/14 3:11:40.000 PM kernel[0]: [0xffffff8014ae4200][free]()
11/03/14 3:11:40.000 PM kernel[0]: ### ERROR: opCode = 0x0406 (Disconnect) -- send request failed (err=0x0012 (kBluetoothHCIErrorInvalidHCICommandParameters))
11/03/14 3:11:44.000 PM kernel[0]: ### ERROR: opCode = 0x0406 (Disconnect) -- send request failed (err=0x0012 (kBluetoothHCIErrorInvalidHCICommandParameters))
11/03/14 3:11:44.000 PM kernel[0]: [0xffffff801409d800][free]()
11/03/14 3:11:52.457 PM coreaudiod[149]: Disabled automatic stack shots because audio IO is active
11/03/14 3:11:52.631 PM coreaudiod[149]: Enabled automatic stack shots because audio IO is inactive
11/03/14 3:11:54.718 PM librariand[657]: MMe quota status changed: under quota
11/03/14 3:11:54.862 PM com.apple.security.pboxd[661]: Bug: 12F45: liblaunch.dylib + 23849 [2F71CAF8-6524-329E-AC56-C506658B4C0C]: 0x25
  • Does it show the BT running in the Activity monitor. Could you also look in the Console and publish few lines of interest. – Ruskes Mar 11 '14 at 0:35
  • Yes Bluetooth is running in the Activity Monitor. Updated OP with Console log. – pknz Mar 11 '14 at 2:22
  • Try going to System Preferences > Bluetooth, then finding the keyboard, right clicking on it, and clicking "Remove" – Arc676 Mar 11 '14 at 2:41
  • The keyboard only appears in the System Preferences > Bluetooth when it prompts to pair, then disappears, and then reappears. I have hit reject on the prompt, and also tried to remove it in System Preferences but the prompts continue. I am now looking into Bluetooth Explorer (Xcode Hardware IO Tool). – pknz Mar 11 '14 at 2:49
1

Your Console shows:

1- The kernel is trying to turn off BT but gets refused!

2- Your os x install has a bug?

They might or not be related.

Reinstall your OS X (12F45) update. ->Check.

Reset your SMC. ->Check.

If problem continues Log in as Guest. ->Check.

  • Reinstalled 12F45. Reset SMC. Issue still occurs. Ran Bluetooth Explorer, reset Connected Apple HID Devices, Full Factory Reset connected Apple Devices, Delete Link Keys from Bluetooth Module, Delete global preference file, Delete All Keys from local software stores, Remove all favourite devices, Unconfigure all configured devices, restart blueooth daemon, restart. Issue still occurs. Rebooted MacBook Air on known good OS, issue still occurs. – pknz Mar 12 '14 at 21:07
  • Darn, a hard one :) – Ruskes Mar 12 '14 at 21:24
  • Yea, I think I'm resigned to tracking down the troublesome keyboard :( – pknz Mar 12 '14 at 21:26
  • it can only be in a 30 feet radius :) did the OS X bug go away in process ? – Ruskes Mar 12 '14 at 21:41
  • I've just tried walking about the building with my Mac laptop with BTScanner (Windows software), iStumblr, and then Setup Bluetooth Keyboard. And I can't detect the keyboard at all. What ties that keyboard to the MacBook Air? It isn't paired, but it connects automatically. – pknz Mar 12 '14 at 23:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .