7

After following the instructions in this answer (briefly: Java prefs pane → Security → disable "Enable Java content in the browser") to disable the Java plug-in globally, I'm presented with an admin password prompt dialog, followed in turn by this dialog:

Dialog reading: "Java Disabled for Current User Only.  Only an Administrator can change the Enable Java in the browser setting for all users on this computer. Java will be disabled in the browser only for the current user" wiht "OK" button

How do I change this setting for all users?

  • 1
    You could remove the corresponding plugin file at /Library/Internet Plugins/JavaAppletPlugin.plugin although that's a bit brutal and not necessarily what you want. – GhostLyrics Mar 18 '14 at 19:31
  • @GhostLyrics That'll do the job temporarily, but I'm not sure what happens on upgrade. – zigg Apr 28 '14 at 15:18
5

The answer is at http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/jcp/properties.html (Java 7) and http://docs.oracle.com/javase/8/docs/technotes/guides/deploy/properties.html (Java 8), though the instructions could be more explicit.

They say to set the deployment.webjava.enabled to false in your deployment.properties file, whose location is defined by the deployment.system.config property in the file ${deployment.java.home}/lib/deploy/deployment.config.

I found that you can just create deployment.properties in ${deployment.java.home}/lib, which I guess is a default location.

This raises the question of what the value of ${deployment.java.home} is, and it's not what I expected. I'm using OS X 10.7.5, and the value of deployment.java.home for me is /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home.

I created a deployment.properties file there with the contents:

deployment.webjava.enabled=false
deployment.webjava.enabled.locked=true

Now, when I open the Java Control Panel and go to the security tab, I see this:

Java Control Panel screenshot showing Java content in browser disabled

There is that nagging "Only disabled for this user" still, but I think that's just a UI bug. If you log in as other users, you'll see that it's disabled for everybody.

  • 1
    Great find! After reading the linked article, I tried /Library/Application Support/Oracle/Java/Deployment/deployment.properties for my config file, which also worked. – zigg Feb 22 '15 at 11:52
3

I had to create dir Deployment in /Library/Application Support/Oracle/Java/

mkdir /Library/Application\ Support/Oracle/Java/Deployment/

and put deployment.config there.

deployment.webjava.enabled=false
deployment.webjava.enabled.locked=true

Now the settings screens looks really disabled.

enter image description here

  • I went with this route as well. I believe it's effectively the same as what @user4851 suggested, but I think folders named Contents on Mac OS are generally best left untouched, whereas Application Support fits the bill perfectly here. Just as in the other answer, the UI still says "Only disabled for this user", but I tried logging in as more than one user and both of them had the "Enable Java content in the browser" checkbox unchecked and greyed out. – nc. Mar 5 '16 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .