1

Whenever I open a PDF in Adobe Acrobat Pro (version of Adobe Creative Cloud) on my Macbook Pro (early 2013 Retina version with NVIDIA GeForce GT 650M 1024 MB) scrolling through the document is unacceptably slow.

In terms of 'frames per second' it would be about 2 fps when scrolling.

Does anyone have a suggestion on how to improve the speed of this? I expect it to run about as smooth as scrolling/viewing a webpage.

Edit: added summary from comments below:

It happens with any PDF, no big difference between 'text only' PDF or one build up with images. Text PDF example: http://www.vivin.net/pub/pdfjs/TestDocument.pdf - still renders too slow.

Also tried with the laptop of a colleague, same Macbook model, same specs, same Acrobat -> same behavior :) I'm amazed why that is so slow. When I open the PDF in Chrome, it is fast (because Chrome has pdfjs integrated, a different viewer). However, I want to solve it with Acrobat.

  • Is the application slow or just scrolling? – Rob Mar 10 '14 at 8:44
  • Just the scrolling of the document, for the rest the application works fine/smooth. – Sander Mar 10 '14 at 8:49
  • Could you try this -- once the document is actually scrolling, adjust the speed by typing any number from 0 to 9 (0 is slowest) – Rob Mar 10 '14 at 9:16
  • all PDF or just specific one? – Ruskes Mar 10 '14 at 9:46
  • I tried a PDF with Text or build up with images, no big difference. Text PDF: vivin.net/pub/pdfjs/TestDocument.pdf - still renders too slow. – Sander Mar 11 '14 at 8:35
1

Acrobat Reader and Pro are bloated. Apple's Preview runs circles around it and that doesn't make sense being Adobe's own Reader and file format should work flawlessly (by now). Pro can do more things like make PDF forms. But ever since Acrobat 5, it's become an overly large Application that runs unacceptably slow.

PDFs were originally intended for books. Later functionally was added for PDF forms, archiving records, printing and prepress. They are doing too much with it and there about almost 20 versions of the PDF file format if your include PDF/X, PDF/A, PDF/E, PDF/VT and PDF/UA in addition to PDF 1.0, 1.1, 1.2, 1.3, 1.4, 1.6, 1.7 2004, 1.7 2006, 1.7 2008, 1.7 2009, 1.7 2011, 1.8, and 1.9.

It's a shame that Adobe can't tame this its own wild beast. Adobe PhotoShop CC and Illustrator CC are excellent. Indesign CC is good with the exception that its Alpha Channel form of PDF transparency is not compatible with Firefox's builtin PDF plugin. Indesign's drop shadows will come out as boxes in both Dropbox and Firefox's internal PDF viewers. As a stone age workaround, you can use PDF 1.3 to flatten the file, but then you face unwanted lines in the web view. InDesign drop shadows have always worked in the inverse of Illustrator's drop shadow transparency which doesn't make any sense with software coming from the same vendor and both were created from scratch (to the best of my knowledge the source code to these two apps were not bought from another company). Adobe needs to get a grip on PDF. It has been too long.

Adobe Indesign was designed to become a QuarkXpress killer. But they lost sight on how its transparency should work and things like Rasterize and Keyline view were omitted. So if you need those additional tools, you have to copy and paste the elements into Illustrator. Turn on PDF in Adobe's clipboard past preferences , do you edits in AI then copy them to InDesign via the clipboard. Waste of time to get decent looking online PDFs from InDesign. It is best to not use Acrobat and InDesign and just use Preview as your viewer or Firefox, and use Illustrator to create decent PDFs that have transparency.

  • Unfortunately I think you're right. So actually the answer is that it currently is technically not possible to have a smooth performance when scrolling in Mac OS X with Adobe Acrobat. My solution to view PDF's in an acceptable way is to use Chrome or Firefox. These have PDFjs integrated and is a very good way to view PDFs. – Sander Apr 7 '14 at 14:44
2

You have to turn on Enable Scrolling from the View menu. I also had that issue before.

  • Thanks for your answer, unfortunately that does not do the trick, it is already on that setting. The issue is that scrolling is terribly slow. – Sander Mar 16 '14 at 22:43
0

Kill all smoothing options in "page Display" preferences, besides "for laptop/LCD screens", and set a custom resolution to 90 ppi. Then speed picks up nicely.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .