I'm trying to copy an object out of an SVG file using inkscape, however when I paste it back in to a new inkscape file it's no longer the svg version, but a rasterized version.
I'm not sure if it's because inkscape runs in XQuartz and the clipboard is behaving odly.


3 Answers 3


Here someone had the same problem. They solved it by turning off X11's Pasteboard Syncing:

Disabling ‘Sync PasteBoard’ Functionality within X11 (Which is Included in XQuartz App for OSX Mountain Lion) solves the problem of converting vector object to Bitmap after pasting the same object in another SVG file.

Do This (Go to): X11 > Click on ‘Preferences’ tab > Choose ‘Pasteboard’ tab > Uncheck ‘Enable Syncing’


I solved this problem by importing another svg file into the current one.

File --> Import... --> Select "All Vectors" (or "*.svg") in the filter selection menu.

This copies the entire content of the imported file into the current one in vector format.


This is not really a solution but a workaround I learned from this page and it requires you to flex those muscle memory of CommandC and then CommandV. The workaround is to use ControlD to duplicate instead of copy and pasting. Off course this does not work if you want to copy from one file to another or in/out of Inkscape.

(It is a shame that Inkscape developers are ignoring all mac users. Looking forwards to see a real native implementation away from crappy X11!)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .