0

I can't add a new contact as keyboard doesn't appear in the Contacts. I have deleted email account from Settings. Also the Contacts service is on in iCloud.

I have an iPhone 4 on iOS 7.

  • Restarting the iPhone doesn't improve issue? – Andrew U. Mar 10 '14 at 11:38
1

Delete any other keyboards you're using like emoji etc then it should be fine.

I was facing the same issue and it resolved only when I deleted the keyboard.

Go to settings, general, keyboard and then look if there are any extra keyboards there.

  • Eliminating second keyboard does the trick. – user105916 Dec 23 '14 at 21:49
0

what do you mean you deleted email account from settings? Did you un-sync an email account which is needed for the contacts? Did you just reset your phone when you try adding contacts?

I have iphone4s and I never had a problem like this when adding contacts(I'm pretty sure iphone4 and 4s aren't so much different from each other).

Try to make sure you have synced an email account first in your settings>Mail, Contacts, Calendars. About icloud7, it's turned on in my phone but I haven't had problems adding more contact. iCloud just syncs your things in your phone and it would make any issues upon adding one.

0

Reboot your phone. Mine just experienced the same problem seconds ago. Turn it off and restart, then it should be fine.

I had to do a hard restart to get the keyboard back.

You must log in to answer this question.

protected by bmike Apr 2 '15 at 21:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .