8

I am stuck with a Boot Camp installation on a new Mac Pro.

I have tried Windows 8.1 Pro, Windows 8.1 Enterprise, and Windows Server 2012 R2. (Can't try Windows 7, obviously.)

All three give me this at the end of setup:

Windows could not update the computer's boot configuration. Installation cannot proceed.

I've tried letting the Boot Camp Assistant do everything, I've also followed the advice in several posts that suggest interrupting the process by booting back into Mac and using Disk Utility to format the Boot Camp partition as FAT, ExFAT, etc. All lead to the same error after rebooting to the USB drive and commencing with Windows setup.

Windows finishes the installation, seemingly, but it just doesn't seem to be able to update the boot data.

So, what's the trick? How did other MacPro6,1 users get Boot Camp paved? Is this a firmware update I'm going to need to wait for?

I tried support, it was a joke. Apple couldn't pass me off to Microsoft quick enough; and Microsoft couldn't pass me back to Apple quick enough. I think that's the most I've ever identified with a tennis ball.

8

Finally got this working, thanks to a person named "turbostar" over on discussions.apple.com:

  1. Re-run Boot Camp Assistant to remove the Windows partition and restore the full Mac HD as a single partition.
  2. Run a PRAM reset (restart, while screen is still black, hold down +Option+P+R and keep them pressed until you hear the startup sound a second time).
  3. Open disk utility and repair permissions on the Macintosh HD partition. TWICE.
  4. Start Boot Camp Assistant again.

Seems hokey. With those instructions I thought I would also have to stand on one foot, point to my nose, rub my belly, and hope for rain. But it did end up working.

  • It worked, but how the heck did this guy come up with the idea to reset PRAM and repair permissions TWICE to get this to work... :P hmmmm didnt work doing it once, let me repeat the whole process and try repairing permissions TWICE! – furier Apr 22 '14 at 12:43
  • @furier yeah, I have absolutely no idea. However, beware, I'm not sure if it was this approach, something else I tried, or one of my ThunderBolt peripherals, but now I get CPU kernel panics when the machine goes to sleep. A fully replaced logic board did not help. I installed an app called caffeine to alleviate the issue, but it is annoying having to be sure it is turned on every time I walk away from the computer. – Aaron Bertrand Apr 22 '14 at 13:06
  • 1
    (P.S. the sleep issue was caused by a J4 Pegasus driver, which was updated later in 2014 and no longer causes the issue.) – Aaron Bertrand Mar 7 '15 at 21:33
  • In high siera you can't run "repair permissions" in disk util. But I tried this and other answers below and nothing seemed to help. Any other ideas? – dardawk Aug 3 '18 at 0:16
2

I faced the same problem on my new 2018 15 inch MacBook Pro. None of the steps above helped me. However, while doing First Aid on Macintosh HD using Disk Utility, I noticed that I was getting the following error: "Warning: crypto: val object (oil:0x04): invalid state".

This was not going away, no matter how many times I did First Aid. While searching for a solution, I read (here: https://forums.developer.apple.com/thread/89882) that one way to fix this issue is to reinstall MacOS. Below are the steps that worked for me, in the exact order.

  1. Reboot machine and go to "Internet Recovery Mode" (Press option + cmd + R while startup)
  2. Connect to internet, select Disk Utility and select Macintosh HD.
  3. Erase the drive using default options. (Warning: You will loose all data in your machine)
  4. Close the utility and go back to the starting screen and select "Reinstall MacOS"
  5. After installation (this will take some time) and minimal setup, download 64-bit Windows 10 iso from Microsoft website (https://www.microsoft.com/en-gb/software-download/windows10ISO)
  6. Reboot the machine, do a PRAM reset (Press option + cmd + P + R while startup)
  7. After booting up, open Disk Utility and do a First Aid. Confirm the error is no longer there.
  8. Open BootCamp Assistant and follow the normal procedure.

The rest of the Windows 10 installation was smooth for me. Hope this helps.

  • The solution from @manuignatius really helps! Thank you. I didn't even have to do the PRAM reset. I just wanted to add (unfortunately I cannot do it in comments yet), that if you need the Windows 10 Education ISO (not Home or professional), like me, you can find it in: microsoft.com/en-au/software-download/vlacademicwindows10iso With this ISO the instalation on MacBook Pro 2018 succeeded without any issues. – user293621 Aug 17 '18 at 9:35
  • Thank you! My installation failed when using a Windows 10 Pro x64 ISO from Microsoft Partner Network downloads. However the x64 ISO from microsoft.com/en-gb/software-download/windows10ISO worked fine. – Robert Claypool Oct 31 '18 at 16:51
1

After I read the above answer I decided to 'Think different'. I think, the PRAM reset is the solution.

I had the same error installing Win10. After klicking the error message away my MacPro rebooted. I hold the ALT key to see my boot options. In my boot options I had my Mac HD, the Recovery partion 10.11.3 and two partitions called Windows.

I tried the third boot option (1. Windows) and after a short while my MacPro shut down. I started it again, did the PRAM reset and held ALT key. This time I selected the fourth boot option (2. Windows) and the Windows setup restarted again. This time whitout any error messages.

After some reboots Win10 was running on my MacPro 2013.

1

@manuignatius and @Andrew Swift are correct. I had to install windows 10 on the newest MBP(15, 2018). Tried everything from other threads nothing and almost all version of versions of windows isos, nothing worked. But using the Windows 10 image from https://www.microsoft.com/fr-fr/software-download/windows10ISO is the only thing that worked for me thus far.

Solution: Use the windows 10 image from https://www.microsoft.com/fr-fr/software-download/windows10ISO

  • This worked for me too. It seems like old Windows installers have issues with the new macs. – Simon Perepelitsa Nov 25 '18 at 7:40
1

I had the exact same issue. I have tried beats all possible solution that I can come up with. I even tried with all listed solution in web forums. I even contacted many representative from the max support including couple of scenery percentage and none of them were able to give me a positive solution but I figured it out. It seems like the Windows version that I use at first place is oldee version and new bootcamp not compatible with it. You need to use a Windows version anything not related then 2018 March. That’s all you had to do. It will work. Good Luck 👍🏼

0

Thats indeed the solution for the problem. But you have to do it in this order. (Assuming, that your windows-partition is behind your MAC OS partition) [this steps are additional comments to http://trueweb.pro/install-windows-10-2010-macbook-pro-a1286/]

  • Create a partition wirh disk-utility

  • Reboot

  • Boot from windows installation media ()

  • Execute the installer

  • When you see the screen, where to choose the partition

    ->> delete the partition, which you've just created with disk-utility

    ->> delete any other partition, that exists after the windows partition

    ->> create one new partition instead of the partition(s) you've deleted just before

  • Format this new partition, by pressing the format button/link

  • proceed with the installation, by choosing the new created partition

Then, the error will appear!

  • Shut down your computer, by holding the power-button down

  • do the PRAM reset ?+Option+P+R TWICE

  • Execute the installation for a second time, by booting another time from your installation media

  • dont delete the partition you've created at the first attempt, just format it and start the installation

  • The error didn't appear in this run

So I managed to have windows 10 running at my macbook.

regards, christian

0

None of the other answers worked for me but I did succeed after a bunch of research.

I installed Windows 10 on new MB Pro (summer 2018) with freshly-wiped hard drive and Mojave installed by restarting in Internet Recovery mode (OS X 10.14 build 18A391).

My first install failed after entering the Windows key, using a build 1607 Windows ISO, with the following error:

Windows could not update the computer's boot configuration. Installation cannot proceed.

Some of what follows is certainly unnecessary.

1. delete the partitions from the failed attempt

Does not delete your files:

  1. restart in recovery mode: restart while holding down cmd+R

  2. in disk utility, click "view" in the top left corner then "Show All Devices"

  3. click on "Apple SSD..." then "Partition"

  4. click on "Boot Camp" then "-" to delete the partition, then "Apply"

  5. quit disk utility then restart from Apple Menu

2. download a current ISO from Microsoft

Using the current (1803) build of Windows 10 may be the only part of all this that is necessary.

https://www.microsoft.com/fr-fr/software-download/windows10ISO

I put the ISO in my home folder, having read that it shouldn't be in Downloads and not wanting it to be in iCloud.

3. disconnect all external devices

Like my USB key with the Windows 10 ISO

4. reset the SMC

Instructions for touch bar MB Pro with T2, other Macs are different.

I used my iPhone for a clock. From shutdown:

  1. press and hold power button for 10 seconds

  2. release button, then wait 5 seconds

  3. press the power button again to turn on Mac

5. reset the NVRAM

Instructions for touch bar MB Pro with T2, other Macs are different

Macs no longer use PRAM. From shutdown:

  1. press power button then immediately press and hold:

    option · command · P · R

  2. release the keys after about 20 seconds, during which the Mac might appear to restart (after the Apple logo appears and disappears for the second time)

6. rerun Boot Camp Assistant

It worked like a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .