10

In OS X 10.9.2, I cannot arrange finder's files and folder by name and the files are sorted by random alphabetical order. Is that a bug or any work around?

1
  • 1
    Problem now appears to be carried over to OS X 10.9.4 - it is possible to arrange files in all view options (overflow etc) EXCEPT column view. Even if you arrange files in another view type, the moment you with to column view, the files and folders are sorted randomly. This has to be an ongoing bug.
    – user84524
    Commented Jul 8, 2014 at 17:36

7 Answers 7

18

Finder offers two sorting methods: Arrange By and Sort By.

In column view:

  1. Click View > Arrange By > None
  2. Hold down the Option key and click View > Sort By > Name

Each folder has a hidden file .DS_Store that controls these settings, so when things don’t redraw correctly after you change a preference, consider trashing that file or making a new clean folder and moving things into a new store.

1
  • 1
    Thanks. This is also useful for another bug, when the list view headers don't respond to mouse clicks
    – Tobia
    Commented Jul 14, 2015 at 14:50
3

Turn off "Arrange By."

For me sort was unavailable, including by clicking the column headers, til I did that.

But this page got me half the way there, the rest was a random brainstorm.

So thanks, denizens of whatever apple.stackexchange.com/questions is. :-D

2

Click View > Arrange By > None.

Hold down the Option key and click View > Sort By > Name.

1

Have you tried changing both the Sort By and Arrange By modes? The Sort By mode can be changed from the view options (command-J), or View > Arrange By turns to Sort By if you hold option.

1

For me (OS 12.5) there was no arrange by option in View. However, I had the View/Use Groups option turned on. Deselecting this option allowed the name column to appear.

1
  • turning off groups in Finder menu View by un-checking Use Groups fixed this for me after updating from macos 12 to 13
    – jimmont
    Commented Jan 7, 2023 at 23:01
0

I got it to alphabetize by holding down Option.

0

If you're having issues with changing the sort order, first sort by "none" and then resort. Holding the option key produces different order options. I solved my column view problem of folders being put at the bottom of the list as opposed to the top of my list using this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .