As the title suggests, My Mac will not receive an address via DHCP from a certain network. No matter if it's connected via WiFi or ethernet, it always fails. Even when I boot into Windows 7 there's no luck (so it's not the OS). All the other computers, older MacBooks, and iPod/Phones work great on the network. Take it to a different network and it works flawlessly.

Has anyone else had this problem? Did you find a way to fix it?

Update: Manually entering a valid IP (copied from another computer that's on the network) gets me a connection. The issue seems to be just in the DHCP.

  • Do you get a 169.254 address or nothing at all? Apr 18, 2011 at 21:22
  • A 169.254... address
    – cpf
    Apr 18, 2011 at 21:39
  • Are you selecting DHCP with manual address or static IP? Apr 18, 2011 at 23:52
  • Setting it to "full" DHCP produces the self-assigned addresses. Static IP worked fine (with up-to-date details). I just cleared the NVRAM and we'll see tomorrow if that did anything at all.
    – cpf
    Apr 19, 2011 at 1:43
  • Turn airport off. Open up console and select "all messages" on the left-hand side. Turn Airport back on. Wait for the airport messages to show up. Paste them here so we can have a look. :-)
    – Harv
    Apr 22, 2011 at 0:53

4 Answers 4


Have you tried to set 'Configure IPv6' to OFF in the Network > Advanced settings for the en0 ?

I've just had a sim problem as yours (never got an address, other windows machines worked) that was resolved by turning it off. Then my IPv4 address was received.

  • Had the exact same issue. Turned off the IPv6 (binary10 answer) and it worked straight away. Thank you
    – user46706
    Apr 4, 2013 at 13:46

Two shots in the dark here: does the network in question require a DHCP Client ID to be set in Network Preferences? (System Preferences > Network > Advanced > TCP/IP)? Some networks do require that.

Second, is the router set to block the MBP's MAC address? That would account for the failure to connect via OS X or Win7. Hard to believe that could be the case, but I suppose it's possible.

  • Neither. I can access it fine on my iPod without doing anything more than selecting it from the network list (after pressing "Forget this network" of course). I can also manually enter a valid IP on my MBP and be connected quite fine; the issue seems to only be the DHCP.
    – cpf
    Apr 18, 2011 at 21:39
  • @Negrino you just saved my day ;)
    – muffel
    Nov 11, 2013 at 11:23

My issue was fixed by clearing the NVRAM (hold ⌘ Command⌥ OptionPR at boot up untill it chimes twice). I never did try the IPV6 thing so that might work, too.


tl;dr Turn off DHCP Reservation on the router/modem in DHCP settings.

My kids both got computers from school. One Macbook Air and one Dell Chomebook. Neither would get a DHCP address on our home network but worked fine everywhere else. After reading this forum and trying all things with no success the solution turned out to be turning off DHCP Reservation on the CenturyLink modem.

All computers worked fine after disabling that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .