7

OS X uses the rubber band effect to show users that they’ve scrolled to the end of a window’s content.

In the past (Lion) the terminal command that follows would disable this effect:

defaults write -g NSScrollViewRubberbanding -int 0

I've tried using Onyx and Tinker Tools to disable this and they do not work. The above terminal command doesn't work either.

Can this scrolling behavior be suppressed or eliminated on 10.9 Mavericks?

  • What is an example of an app this is occurring in? I tried scrolling in Safari and Mail and did not see the effect. – dwightk Mar 6 '14 at 20:05
  • For me it happens in Finder, Safari, Mail. And I am sure many others. – GEdgar Mar 6 '14 at 20:34
  • 1
    Ah, this only happens when scrolling using the trackpad. – dwightk Mar 6 '14 at 20:40
  • I find rubber banding to be terribly annoying and distracting. I'd pay good money if we could turn this annoyance and other animations off. Simply hate that useless behavior. – Alex Zavatone Nov 21 '14 at 15:38
1

There is no known solution at the moment – Apple seems to have deprecated the NSScrollViewRubberbanding command in 10.9.

You may find that it helps to do Settings > Accessibility > Mouse & Trackpad > Trackpad Options > Scrolling > Without Inertia. This won't actually disable the rubber band effect, but in my experience it makes it less annoying.

Source: https://discussions.apple.com/message/23778772#23778772

Supposedly Cocktail may eliminate the bouncing, but reports are mixed.

  • Thank you for the Cocktail suggestion, I tried it, but it didn't solve the problem, despite there being a checkbox option to disable the rubber band scrolling. – Cole Garstin Mar 28 '14 at 6:05
  • 1
    Hmm, i find "inertia" very helpful, and "elastic scroll" very disruptive. – Alexey Apr 3 '14 at 17:24
  • Cocktail won't fix it as it uses the published and deprecated NSScrollViewRubberBanding. – Alex Zavatone Nov 21 '14 at 15:39
  • Alexy, I think you have summed it up. I also find "inertia" very helpful and pleasing and rubber banding infuriating, useless and a terrible distraction that you can not disable. The UI team needs to be beaten for forcing this on us. – Alex Zavatone Nov 21 '14 at 15:41
-1

Just add a -webkit-overflow-scrolling: auto; to the div you want to prevent from bouncing

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .