I am trying to use the default built in apple RDP client to RDP into my Windows 8.1 box but I keep getting the following problem:

Remote Desktop Connection for Mac OSX - cannot verify the identity of the computer

I've tried a combination of several ways but nothing.

Everything is fine windows to windows.

---not sure what I am doing wrong here.

I was not aware that Apple shipped a native RDP app, but regardless. I use the one from Microsoft and it works great:

https://itunes.apple.com/us/app/microsoft-remote-desktop/id715768417?mt=12

There is an older one available for direct download from Microsoft but I've used both and prefer the new one. Never had a problem with it and it's FREE.

If you are using "Microsoft Remote Desktop Connection Client for Mac 2.1.1" and do not want to upgrade to "Microsoft Remote Desktop", then the following applies. This was tested using OS X 10.10.2 (Yosemite).

The problem is on the Windows 8.1 machine. Make the following changes on the Windows machine.

Enable RDP security layer in Group Policy on the machine:

  1. Verify that the firewall allows remote desktop connections with RDP (Port 3389). For private networks, this can be verified by making sure the "Allow remote connections to this computer" button is selected in the System Properties window. To reach the System Properties window, first click the System icon on the Control Panel, then click on "Advanced system settings".

enter image description here

  1. Right click on the Windows icon in the lower left corner of the Desktop. Select Run from the pop up menu.

  2. Type gpedit.msc and click "OK" Result: The Group Policy Editor will open.

  3. In the left hand side bar, expand Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Session Host. (Note: In the image below, the Standard tab was selected.)

enter image description here

  1. Select "Security".

enter image description here

  1. Change "Require use of specific security layer for remote desktop (RDP) connection" to Enabled" and select "RDP" in the Options pane.

enter image description here

  1. Change "Require user authentication for remote connections by using Network Level Authentication" to "Disabled."

enter image description here

  1. Close Group Policy Editor and reboot the machine for changes to take effect.

Source: Establishing an RDP connection with a Windows 8.1 client from Mac OS X

Here's what worked for me. The latest version of Microsoft Remote Desktop shows to enter the user name as "DOMAIN\user name". Well this won't work with Windows 10. I entered my username as "username@domain.com" and voila! It worked. Hope this helps someone as frustrated as myself.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.